Privilege escalation for users who hold the “splunk_app_soar“ role in the Splunk App for SOAR
Priority LOW 30CWE-269Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
In versions 1.0.67 and lower of the Splunk App for SOAR, the Splunk documentation for that app recommended adding the `admin_all_objects` capability to the `splunk_app_soar` role. This addition could lead to improper access control for a low-privileged user that does not hold the "admin" Splunk roles.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00264 18th percentileScored 2026-11-07
Fix Fixed Splunk App for SOAR (Splunk): 1.0.71
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Splunk App for SOAR (Splunk) Fixed in 1.0.71
Timeline
- 2026-10-02 Threatist record created from CVE-2025-22621
- 2026-10-03 Alias added: GHSA-rg8w-4hqw-2p27
References
More Splunk vulnerabilities
- TI-2026-16444 Unauthenticated Arbitrary File Creation and Truncation in a PostgreSQL Sidecar Service Endpoint in Splunk Enterprise KEVCVSS 3.1CRITICAL 9.8
- TI-2014-00154 The (1) TLS and (2) DTLS implementations in OpenSSL 1.0.1 before 1.0.1g do not properly… KEVCVSS 3.1HIGH 7.5
- TI-2023-24841 Remote code execution (RCE) in Splunk Enterprise through Insecure XML Parsing CVSS 3.1HIGH 8.8
- TI-2023-12257 Injection in https://github.com/curl/curl CVSS 3.1CRITICAL 9.8
- TI-2022-13930 Information disclosure in https://github.com/curl/curl CVSS 3.1CRITICAL 9.8
- TI-2022-13917 Incorrect default permissions in https://github.com/curl/curl CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-22621 · CVE Program
- CVE-2025-22621 · NVD
- FIRST EPSS
- GHSA-rg8w-4hqw-2p27 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences