Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 4 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat.
Summary
Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Cassandra | 3.0.0 – 3.0.30; 3.1.0 – 3.11.17; 4.0.0 – 4.0.15; 4.1.0 – 4.1.7; 5.0.0 – 5.0.2 | — | No fix listed | CNA |
| — | org.apache.cassandra:cassandra-all (Maven) | 5.0-alpha1 to before 5.0.3 | 5.0.3 | Patch available | GHSA-wmcc-9vch-jmx4 |
| — | org.apache.cassandra:cassandra-all (Maven) | 4.1-alpha1 to before 4.1.8 | 4.1.8 | Patch available | GHSA-wmcc-9vch-jmx4 |
| — | org.apache.cassandra:cassandra-all (Maven) | 4.0-alpha1 to before 4.0.16 | 4.0.16 | Patch available | GHSA-wmcc-9vch-jmx4 |
| — | org.apache.cassandra:cassandra-all (Maven) | 3.1 to before 3.11.18 | 3.11.18 | Patch available | GHSA-wmcc-9vch-jmx4 |
| — | org.apache.cassandra:cassandra-all (Maven) | before 3.0.31 | 3.0.31 | Patch available | GHSA-wmcc-9vch-jmx4 |
- Apache Cassandra VendorApache Affected 3.0.0 – 3.0.30; 3.1.0 – 3.11.17; 4.0.0 – 4.0.15; 4.1.0 – 4.1.7; 5.0.0 – 5.0.2 Fixed in — No fix listed CNA
- org.apache.cassandra:cassandra-all (Maven) Vendor— Affected 5.0-alpha1 to before 5.0.3 Fixed in 5.0.3 Patch available GHSA-wmcc-9vch-jmx4
- org.apache.cassandra:cassandra-all (Maven) Vendor— Affected 4.1-alpha1 to before 4.1.8 Fixed in 4.1.8 Patch available GHSA-wmcc-9vch-jmx4
- org.apache.cassandra:cassandra-all (Maven) Vendor— Affected 4.0-alpha1 to before 4.0.16 Fixed in 4.0.16 Patch available GHSA-wmcc-9vch-jmx4
- org.apache.cassandra:cassandra-all (Maven) Vendor— Affected 3.1 to before 3.11.18 Fixed in 3.11.18 Patch available GHSA-wmcc-9vch-jmx4
- org.apache.cassandra:cassandra-all (Maven) Vendor— Affected before 3.0.31 Fixed in 3.0.31 Patch available GHSA-wmcc-9vch-jmx4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:cassandra:*:*:*:*:*:*:*:* | 3.0.0 to before 3.0.31; 3.1 to before 3.11.18; 4.0.0 to before 4.0.16; 4.1.0 to before 4.1.8; 5.0.0 to before 5.0.3 | Vulnerable | Apache |
- cpe:2.3:a:apache:cassandra:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.0.31; 3.1 to before 3.11.18; 4.0.0 to before 4.0.16; 4.1.0 to before 4.1.8; 5.0.0 to before 5.0.3 Vulnerable ·Apache
Remediation
- Fix · GHSA-wmcc-9vch-jmx4 org.apache.cassandra:cassandra-all (Maven) Fixed in 5.0.3 Advisory →
- Fix · GHSA-wmcc-9vch-jmx4 org.apache.cassandra:cassandra-all (Maven) Fixed in 4.1.8 Advisory →
- Fix · GHSA-wmcc-9vch-jmx4 org.apache.cassandra:cassandra-all (Maven) Fixed in 4.0.16 Advisory →
- Fix · GHSA-wmcc-9vch-jmx4 org.apache.cassandra:cassandra-all (Maven) Fixed in 3.11.18 Advisory →
- Fix · GHSA-wmcc-9vch-jmx4 org.apache.cassandra:cassandra-all (Maven) Fixed in 3.0.31 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Data Grid 8 | Affected | No fix planned: Will not fix |
| Red Hat Fuse 7 | Affected | No fix planned: Out of support scope |
| Red Hat Integration Camel K 1 | Affected | No fix planned: Will not fix |
| Red Hat JBoss Data Grid 7 | Affected | No fix planned: Out of support scope |
Not affected: 5 products
- A-MQ Clients 2
- Red Hat JBoss Enterprise Application Platform 7
- Red Hat JBoss Enterprise Application Platform 8
- Red Hat JBoss Enterprise Application Platform Expansion Pack
- streams for Apache Kafka
Timeline
- 2026-10-02 Threatist record created from CVE-2025-23015
- 2026-10-03 Alias added: GHSA-wmcc-9vch-jmx4
References
Advisory 5
More Apache Cassandra vulnerabilities
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2021-20121 Remote code execution for scripted UDFs CVSS 3.1CRITICAL 9.1
- TI-2019-02233 Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent… CVSS 3.1MEDIUM 5.9
- TI-2018-05793 Missing authentication in Apache Cassandra CVSS 3.0CRITICAL 9.8
- TI-2016-04292 handler/ssl/OpenSslEngine.java in Netty 4.0.x before 4.0.37.Final and 4.1.x before… CVSS 3.1HIGH 7.5
- TI-2015-00197 The default configuration in Apache Cassandra 1.2.0 through 1.2.19, 2.0.0 through 2.0.13… CVSS 2.0HIGH 7.5
Sources
- CVE-2025-23015 · CVE Program
- CVE-2025-23015 · NVD
- FIRST EPSS
- GHSA-wmcc-9vch-jmx4 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-23015 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences