Various security vulnerabilities in Extension:DataTransfer
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering, Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-352 and CWE-79.
Summary
Cross-Site Request Forgery (CSRF), Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - DataTransfer Extension allows Cross Site Request Forgery, Cross-Site Scripting (XSS).This issue affects Mediawiki - DataTransfer Extension: from 1.39.X before 1.39.11, from 1.41.X before 1.41.3, from 1.42.X before 1.42.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Wikimedia Foundation | Mediawiki - DataTransfer Extension | 1.39.x to before 1.39.11; 1.41.x to before 1.41.3; 1.42.x to before 1.42.2 | 1.39.11, 1.41.3, 1.42.2 | Patch available | CNA |
| — | mediawiki/data-transfer (Packagist) | 1.39.0 to before 1.39.11 | 1.39.11 | Patch available | GHSA-c3h5-h73c-29hq |
| — | mediawiki/data-transfer (Packagist) | 1.41.0 to before 1.41.3 | 1.41.3 | Patch available | GHSA-c3h5-h73c-29hq |
| — | mediawiki/data-transfer (Packagist) | 1.42.0 to before 1.42.2 | 1.42.2 | Patch available | GHSA-c3h5-h73c-29hq |
- Mediawiki - DataTransfer Extension VendorWikimedia Foundation Affected 1.39.x to before 1.39.11; 1.41.x to before 1.41.3; 1.42.x to before 1.42.2 Fixed in 1.39.11, 1.41.3, 1.42.2 Patch available CNA
- mediawiki/data-transfer (Packagist) Vendor— Affected 1.39.0 to before 1.39.11 Fixed in 1.39.11 Patch available GHSA-c3h5-h73c-29hq
- mediawiki/data-transfer (Packagist) Vendor— Affected 1.41.0 to before 1.41.3 Fixed in 1.41.3 Patch available GHSA-c3h5-h73c-29hq
- mediawiki/data-transfer (Packagist) Vendor— Affected 1.42.0 to before 1.42.2 Fixed in 1.42.2 Patch available GHSA-c3h5-h73c-29hq
Remediation
- Fix · CNA Mediawiki - DataTransfer Extension (Wikimedia Foundation) Fixed in 1.39.11, 1.41.3, 1.42.2
- Fix · GHSA-c3h5-h73c-29hq mediawiki/data-transfer (Packagist) Fixed in 1.39.11 Advisory →
- Fix · GHSA-c3h5-h73c-29hq mediawiki/data-transfer (Packagist) Fixed in 1.41.3 Advisory →
- Fix · GHSA-c3h5-h73c-29hq mediawiki/data-transfer (Packagist) Fixed in 1.42.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-23081
- 2026-10-03 Alias added: GHSA-c3h5-h73c-29hq
References
Other 8
- https://phabricator.wikimedia.org/T379749
- https://gerrit.wikimedia.org/r/q/I773c616db781d2f3f30893ad01ef503bf251a2b3
- https://gerrit.wikimedia.org/r/q/I7c9de4c8dcdb3276ba923c6bc7c8eef3531324c7
- https://gerrit.wikimedia.org/r/q/I9223c31f02f31f1e06e1a8cddf7d539cc8d3a3d9
- https://gerrit.wikimedia.org/r/q/I5e1538a3bf66378810f905834c05626e1d2c82f0
- https://gerrit.wikimedia.org/r/c/mediawiki/extensions/DataTransfer/+/1093931
- https://gerrit.wikimedia.org/r/c/mediawiki/extensions/DataTransfer/+/1080451
- https://github.com/wikimedia/mediawiki-extensions-DataTransfer
More Wikimedia Foundation vulnerabilities
- TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
- TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
- TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
- TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
- TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
- TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
Sources
- CVE-2025-23081 · CVE Program
- CVE-2025-23081 · NVD
- FIRST EPSS
- GHSA-c3h5-h73c-29hq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences