misc: pci_endpoint_test: Avoid issue of interrupts remaining after request_irq error
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: misc: pci_endpoint_test: Avoid issue of interrupts remaining after request_irq error After devm_request_irq() fails with error in pci_endpoint_test_request_irq(), the pci_endpoint_test_free_irq_vectors() is called assuming that all IRQs have been released. However, some requested IRQs remain unreleased, so there are still /proc/irq/* entries remaining, and this results in WARN() with the following message: remove_proc_entry: removing non-empty directory 'irq/30', leaking at least 'pci-endpoint-test.0' WARNING: CPU: 0 PID: 202 at fs/proc/generic.c:719 remove_proc_entry +0x190/0x19c To solve this issue, set the number of remaining IRQs to test->num_irqs, and release IRQs in advance by calling pci_endpoint_test_release_irq(). [kwilczynski: commit log]
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.19 and later | 5.4.293, 5.10.237, 5.15.181, 6.1.135, 6.6.88, 6.12.25, 6.14.3, 6.15 | Patch available | CNA |
- Linux VendorLinux Affected 4.19 and later Fixed in 5.4.293, 5.10.237, 5.15.181, 6.1.135, 6.6.88, 6.12.25, 6.14.3, 6.15 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.19 to before 5.4.293; 5.5 to before 5.10.237; 5.11 to before 5.15.181; 5.16 to before 6.1.135; 6.2 to before 6.6.88; 6.7 to before 6.12.25; 6.13 to before 6.14.3 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.19 to before 5.4.293; 5.5 to before 5.10.237; 5.11 to before 5.15.181; 5.16 to before 6.1.135; 6.2 to before 6.6.88; 6.7 to before 6.12.25; 6.13 to before 6.14.3 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.293, 5.10.237, 5.15.181, 6.1.135, 6.6.88, 6.12.25, 6.14.3, 6.15
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-23140
- 2026-10-03 Alias added: GHSA-vvgj-gr7g-xwww
References
Patch 8
- https://git.kernel.org/stable/c/705be96504779e4a333ea042b4779ea941f0ace9
- https://git.kernel.org/stable/c/e516e187bf32d8decc7c7d0025ae4857cad13c0e
- https://git.kernel.org/stable/c/54c9f299ad7d7c4be5d271ed12d01a59e95b8907
- https://git.kernel.org/stable/c/9d5118b107b1a2353ed0dff24404aee2e6b7ca0a
- https://git.kernel.org/stable/c/5a4b7181213268c9b07bef8800905528435db44a
- https://git.kernel.org/stable/c/0557e70e2aeba8647bf5a950820b67cfb86533db
- https://git.kernel.org/stable/c/770407f6173f4f39f4e2c1b54422b79ce6c98bdb
- https://git.kernel.org/stable/c/f6cb7828c8e17520d4f5afb416515d3fae1af9a9
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-23140 · CVE Program
- CVE-2025-23140 · NVD
- FIRST EPSS
- GHSA-vvgj-gr7g-xwww · GitHub Advisory Database · CC BY 4.0
- CVE-2025-23140 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences