Improper Input Validation in Bible Module for ROBLOX
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Bible Module is a tool designed for ROBLOX developers to integrate Bible functionality into their games. The `FetchVerse` and `FetchPassage` functions in the Bible Module are susceptible to injection attacks due to the absence of input validation. This vulnerability could allow an attacker to manipulate the API request URLs, potentially leading to unauthorized access or data tampering. This issue has been addressed in version 0.0.3. All users are advised to upgrade. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| devycreates | Bible-Module | before 0.0.3 | 0.0.3 | Patch available | CNA |
- Bible-Module Vendordevycreates Affected before 0.0.3 Fixed in 0.0.3 Patch available CNA
Remediation
- Fix · CNA Bible-Module (devycreates) Fixed in 0.0.3
Timeline
- 2026-10-02 Threatist record created from CVE-2025-23202
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences