Rancher: Restricted Administrator can change Administrator's passwords
Priority MEDIUM 42CWE-266Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-266.
Summary
A Incorrect Privilege Assignment vulnerability in SUSE rancher allows a Restricted Administrator to change the password of Administrators and take over their accounts. This issue affects rancher: from 2.8.0 before 2.8.14, from 2.9.0 before 2.9.8, from 2.10.0 before 2.10.4.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00474 41st percentileScored 2026-11-07
Fix Fixed rancher (SUSE): 2.8.14, 2.9.8, 2.10.4github.com/rancher/rancher (Go): 2.8.14, 2.9.8, 2.10.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | rancher | 2.8.0 to before 2.8.14; 2.9.0 to before 2.9.8; 2.10.0 to before 2.10.4 | 2.8.14, 2.9.8, 2.10.4 | Patch available | CNA |
| — | github.com/rancher/rancher (Go) | 2.8.0 to before 2.8.14 | 2.8.14 | Patch available | GHSA-8p83-cpfg-fj3g |
| — | github.com/rancher/rancher (Go) | 2.9.0 to before 2.9.8 | 2.9.8 | Patch available | GHSA-8p83-cpfg-fj3g |
| — | github.com/rancher/rancher (Go) | 2.10.0 to before 2.10.4 | 2.10.4 | Patch available | GHSA-8p83-cpfg-fj3g |
- rancher VendorSUSE Affected 2.8.0 to before 2.8.14; 2.9.0 to before 2.9.8; 2.10.0 to before 2.10.4 Fixed in 2.8.14, 2.9.8, 2.10.4 Patch available CNA
- github.com/rancher/rancher (Go) Vendor— Affected 2.8.0 to before 2.8.14 Fixed in 2.8.14 Patch available GHSA-8p83-cpfg-fj3g
- github.com/rancher/rancher (Go) Vendor— Affected 2.9.0 to before 2.9.8 Fixed in 2.9.8 Patch available GHSA-8p83-cpfg-fj3g
- github.com/rancher/rancher (Go) Vendor— Affected 2.10.0 to before 2.10.4 Fixed in 2.10.4 Patch available GHSA-8p83-cpfg-fj3g
Remediation
- Fix · CNA rancher (SUSE) Fixed in 2.8.14, 2.9.8, 2.10.4
- Fix · GHSA-8p83-cpfg-fj3g github.com/rancher/rancher (Go) Fixed in 2.8.14 Advisory →
- Fix · GHSA-8p83-cpfg-fj3g github.com/rancher/rancher (Go) Fixed in 2.9.8 Advisory →
- Fix · GHSA-8p83-cpfg-fj3g github.com/rancher/rancher (Go) Fixed in 2.10.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-23391
- 2026-10-03 Alias added: GHSA-8p83-cpfg-fj3g
References
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-23391 · CVE Program
- CVE-2025-23391 · NVD
- FIRST EPSS
- GHSA-8p83-cpfg-fj3g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences