ps_contactinfo has potential XSS due to usage of the nofilter tag in template
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
ps_contactinfo, a PrestaShop module for displaying store contact information, has a cross-site scripting (XSS) vulnerability in versions up to and including 3.3.2. This can not be exploited in a fresh install of PrestaShop, only shops made vulnerable by third party modules are concerned. For example, if the shop has a third party module vulnerable to SQL injections, then ps_contactinfo might execute a stored cross-site scripting in formatting objects. Commit d60f9a5634b4fc2d3a8831fb08fe2e1f23cbfa39 keeps formatted addresses from displaying a XSS stored in the database, and the fix is expected to be available in version 3.3.3. No workarounds are available aside from applying the fix and keeping all modules maintained and update.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PrestaShop | ps_contactinfo | up to 3.3.2 | — | No fix listed | CNA |
| — | prestashop/ps_contactinfo (Packagist) | before 3.3.3 | 3.3.3 | Patch available | GHSA-35pq-7pv2-2rfw |
- ps_contactinfo VendorPrestaShop Affected up to 3.3.2 Fixed in — No fix listed CNA
- prestashop/ps_contactinfo (Packagist) Vendor— Affected before 3.3.3 Fixed in 3.3.3 Patch available GHSA-35pq-7pv2-2rfw
Remediation
- Fix · GHSA-35pq-7pv2-2rfw prestashop/ps_contactinfo (Packagist) Fixed in 3.3.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-24027
- 2026-10-03 Alias added: GHSA-35pq-7pv2-2rfw
References
More PrestaShop vulnerabilities
- TI-2024-27717 An issue in Prestashop v.8.1.7 and before allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
- TI-2023-14167 Prestashop posstaticfooter <= 1.0.0 is vulnerable to SQL Injection via posstaticfooter::getPosCurrentHook(). CVSS 3.1CRITICAL 9.8
- TI-2023-14166 Prestashop possearchproducts 1.7 is vulnerable to SQL Injection via PosSearch::find(). CVSS 3.1CRITICAL 9.8
- TI-2023-10662 PrestaShop dpdfrance <6.1.3 is vulnerable to SQL Injection via dpdfrance/ajax.php. CVSS 3.1CRITICAL 9.8
- TI-2024-23013 PrestaShop vulnerable to XSS via customer contact form in FO, through file upload CVSS 3.1CRITICAL 9.7
- TI-2023-14154 An SQL injection vulnerability in the Payplug (payplug) module for PrestaShop, in… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-24027 · CVE Program
- CVE-2025-24027 · NVD
- FIRST EPSS
- GHSA-35pq-7pv2-2rfw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences