In OpenSC pam_pkcs11 before 0.6.13, pam_sm_authenticate() wrongly returns PAM_IGNORE in…
Priority LOW 31CWE-393Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In OpenSC pam_pkcs11 before 0.6.13, pam_sm_authenticate() wrongly returns PAM_IGNORE in many error situations (such as an error triggered by a smartcard before login), allowing authentication bypass.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00229 13th percentileScored 2026-11-07
Fix Fixed pam_pkcs11 (OpenSC project): 0.6.13
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenSC project | pam_pkcs11 | 0.6.12 to before 0.6.13 | 0.6.13 | Patch available | CNA |
- pam_pkcs11 VendorOpenSC project Affected 0.6.12 to before 0.6.13 Fixed in 0.6.13 Patch available CNA
Remediation
- Fix · CNA pam_pkcs11 (OpenSC project) Fixed in 0.6.13
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2025-24531
References
More OpenSC project vulnerabilities
- TI-2009-01519 src/tools/pkcs11-tool.c in pkcs11-tool in OpenSC 0.11.7, when used with unspecified… CVSS 3.1HIGH 7.5
- TI-2010-04253 Multiple stack-based buffer overflows in libopensc in OpenSC 0.11.13 and earlier allow… CVSS 2.0HIGH 7.2
- TI-2008-03811 pkcs15-tool in OpenSC before 0.11.6 does not apply security updates to a smart card… CVSS 2.0MEDIUM 6.6
- TI-2008-02146 OpenSC before 0.11.5 uses weak permissions (ADMIN file control information of 00) for the… CVSS 2.0MEDIUM 4.9
- TI-2009-00348 OpenSC before 0.11.7 allows physically proximate attackers to bypass intended PIN… CVSS 2.0LOW 2.1
Sources
- CVE-2025-24531 · CVE Program
- CVE-2025-24531 · NVD
- FIRST EPSS
- CVE-2025-24531 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences