Fast DDS does not verify Permissions CA
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-345.
Summary
eprosima Fast DDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to versions 2.6.10, 2.10.7, 2.14.5, 3.0.2, 3.1.2, and 3.2.0, per design, PermissionsCA is not full chain validated, nor is the expiration date validated. Access control plugin validates only the S/MIME signature which causes an expired PermissionsCA to be taken as valid. Even though this issue is responsible for allowing `governance/permissions` from an expired PermissionsCA and having the system crash when PermissionsCA is not self-signed and contains the full-chain, the impact is low. Versions 2.6.10, 2.10.7, 2.14.5, 3.0.2, 3.1.2, and 3.2.0 contain a fix for the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| eProsima | Fast-DDS | before 2.6.10; 2.7.0 to before 2.10.7; 2.11.0 to before 2.14.5; 3.0.0 to before 3.0.2; 3.1.0 to before 3.1.2 | 2.6.10, 2.10.7, 2.14.5, 3.0.2, 3.1.2 | Patch available | CNA |
- Fast-DDS VendoreProsima Affected before 2.6.10; 2.7.0 to before 2.10.7; 2.11.0 to before 2.14.5; 3.0.0 to before 3.0.2; 3.1.0 to before 3.1.2 Fixed in 2.6.10, 2.10.7, 2.14.5, 3.0.2, 3.1.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:eprosima:fast_dds:*:*:*:*:*:*:*:* | before 2.6.10; 2.10.0 to before 2.10.7; 2.14.0 to before 2.14.5; 3.0.0 to before 3.0.2; 3.1.0 to before 3.1.2 | Vulnerable | eProsima |
- cpe:2.3:a:eprosima:fast_dds:*:*:*:*:*:*:*:* Versions before 2.6.10; 2.10.0 to before 2.10.7; 2.14.0 to before 2.14.5; 3.0.0 to before 3.0.2; 3.1.0 to before 3.1.2 Vulnerable ·eProsima
Remediation
- Fix · CNA Fast-DDS (eProsima) Fixed in 2.6.10, 2.10.7, 2.14.5, 3.0.2, 3.1.2
Timeline
- 2026-10-02 Threatist record created from CVE-2025-24807
References
Other 4
- https://github.com/eProsima/Fast-DDS/blob/2.6.9/src/cpp/security/accesscontrol/Permissions.cpp#L390-L396
- https://github.com/eProsima/Fast-DDS/blob/2.6.9/src/cpp/security/accesscontrol/Permissions.cpp#L412
- https://github.com/eProsima/Fast-DDS/blob/2.6.9/src/cpp/security/authentication/PKIDH.cpp#L241
- https://www.omg.org/spec/DDS-SECURITY/1.1/PDF
More eProsima Fast Dds vulnerabilities
- TI-2025-38815 Integer overflow in eProsima Fast-DDS CVSS 3.1HIGH 8.6
- TI-2024-18790 Manipulated DATA Submessage causes a heap-buffer-overflow error CVSS 3.1CRITICAL 9.7
- TI-2023-27485 Disconnect Vulnerability in RTPS Packets Used by SROS2 CVSS 3.1CRITICAL 9.7
- TI-2024-20005 FastDDS heap buffer overflow when publisher sends malformed packet CVSS 3.1HIGH 8.2
- TI-2023-20840 Another heap overflow in push_back_helper CVSS 3.1HIGH 8.2
- TI-2023-20839 Heap overflow in push_back_helper due to a CDR message CVSS 3.1HIGH 8.2
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences