Read the docs
TI-2025-18909 Aliases CVE-2025-25247GHSA-4c37-7m5h-c8m9

Apache Felix Webconsole: XSS in services console

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.

Summary

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Felix Webconsole. This issue affects Apache Felix Webconsole 4.x up to 4.9.8 and 5.x up to 5.0.8. Users are recommended to upgrade to version 4.9.10 or 5.0.10 or higher, which fixes the issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00694 53rd percentileScored 2026-11-07
Fix Partial org.apache.felix:org.apache.felix.webconsole (Maven): 4.9.10, 5.0.10Red Hat: 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Felix WebconsoleVersion 4.x – 4.9.8; Version 5.x – 5.0.8—No fix listedCNA
—org.apache.felix:org.apache.felix.webconsole (Maven)4.0.0 to before 4.9.104.9.10Patch availableGHSA-4c37-7m5h-c8m9
—org.apache.felix:org.apache.felix.webconsole (Maven)5.0.0 to before 5.0.105.0.10Patch availableGHSA-4c37-7m5h-c8m9
  • Apache Felix Webconsole VendorApache Affected Version 4.x – 4.9.8; Version 5.x – 5.0.8 Fixed in — No fix listed CNA
  • org.apache.felix:org.apache.felix.webconsole (Maven) Vendor— Affected 4.0.0 to before 4.9.10 Fixed in 4.9.10 Patch available GHSA-4c37-7m5h-c8m9
  • org.apache.felix:org.apache.felix.webconsole (Maven) Vendor— Affected 5.0.0 to before 5.0.10 Fixed in 5.0.10 Patch available GHSA-4c37-7m5h-c8m9

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:felix_webconsole:*:*:*:*:*:*:*:*4.0.0 to before 4.9.10; 5.0.0 to before 5.0.10VulnerableApache
  • cpe:2.3:a:apache:felix_webconsole:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.9.10; 5.0.0 to before 5.0.10 Vulnerable ·Apache

Remediation

  • Fix · GHSA-4c37-7m5h-c8m9 org.apache.felix:org.apache.felix.webconsole (Maven) Fixed in 4.9.10 Advisory →
  • Fix · GHSA-4c37-7m5h-c8m9 org.apache.felix:org.apache.felix.webconsole (Maven) Fixed in 5.0.10 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Fuse 7AffectedNo fix planned: Out of support scope

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-25247
  2. 2026-10-03 Alias added: GHSA-4c37-7m5h-c8m9

References

Sources