Regular expression denial of service in octokit plugin-paginate-rest.js
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Partial Red Hat: 5 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-1333.
Summary
@octokit/plugin-paginate-rest is the Octokit plugin to paginate REST API endpoint responses. For versions starting in 1.0.0 and prior to 11.4.1 of the npm package `@octokit/plugin-paginate-rest`, when calling `octokit.paginate.iterator()`, a specially crafted `octokit` instance—particularly with a malicious `link` parameter in the `headers` section of the `request`—can trigger a ReDoS attack. Version 11.4.1 contains a fix for the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| octokit | plugin-paginate-rest.js | 1.0.0 to before 11.4.1 | 11.4.1 | Patch available | CNA |
| — | @octokit/plugin-paginate-rest (npm) | 9.3.0-beta.1 to before 11.4.1 | 11.4.1 | Patch available | GHSA-h5c3-5r3r-rr8q |
| — | @octokit/plugin-paginate-rest (npm) | 1.0.0 to before 9.2.2 | 9.2.2 | Patch available | GHSA-h5c3-5r3r-rr8q |
- plugin-paginate-rest.js Vendoroctokit Affected 1.0.0 to before 11.4.1 Fixed in 11.4.1 Patch available CNA
- @octokit/plugin-paginate-rest (npm) Vendor— Affected 9.3.0-beta.1 to before 11.4.1 Fixed in 11.4.1 Patch available GHSA-h5c3-5r3r-rr8q
- @octokit/plugin-paginate-rest (npm) Vendor— Affected 1.0.0 to before 9.2.2 Fixed in 9.2.2 Patch available GHSA-h5c3-5r3r-rr8q
Remediation
- Fix · CNA plugin-paginate-rest.js (octokit) Fixed in 11.4.1
- Fix · GHSA-h5c3-5r3r-rr8q @octokit/plugin-paginate-rest (npm) Fixed in 11.4.1 Advisory →
- Fix · GHSA-h5c3-5r3r-rr8q @octokit/plugin-paginate-rest (npm) Fixed in 9.2.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Multicluster Engine for Kubernetes | Affected | No fix planned: Will not fix |
| OpenShift Serverless | Affected | No fix yet |
| Red Hat Advanced Cluster Management for Kubernetes 2 | Affected | No fix planned: Will not fix |
| Red Hat Integration Camel K 1 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Dev Spaces | Affected | No fix planned: Will not fix |
Not affected: 3 products
- Red Hat Developer Hub 1
- Red Hat JBoss Enterprise Application Platform 8
- Red Hat JBoss Enterprise Application Platform Expansion Pack
Timeline
- 2026-10-02 Threatist record created from CVE-2025-25288
- 2026-10-03 Alias added: GHSA-h5c3-5r3r-rr8q
- 2026-10-27 Affected versions changed · Red Hat
- 2026-10-30 EPSS moved to the 50th–90th percentile
References
Other 5
- https://github.com/octokit/plugin-paginate-rest.js/security/advisories/GHSA-h5c3-5r3r-rr8q
- https://github.com/octokit/plugin-paginate-rest.js/commit/bb6c4f945d8023902cf387391d2b2209261044ab
- https://github.com/octokit/plugin-paginate-rest.js/blob/main/src/iterator.ts
- https://github.com/octokit/plugin-paginate-rest.js
- https://github.com/octokit/plugin-paginate-rest.js/releases/tag/v9.2.2
More octokit vulnerabilities
- TI-2025-18944 Regular expression denial of service in octokit request.js CVSS 3.1MEDIUM 5.3
- TI-2025-18943 Regular expression denial of service in octokit request-error.js CVSS 3.1MEDIUM 5.3
- TI-2025-18939 @octokit/endpoint has a Regular Expression in parse that Leads to ReDoS Vulnerability Due to Catastrophic Backtracking CVSS 3.1MEDIUM 5.3
- TI-2023-27674 Unauthenticated Denial of Service in the octokit/webhooks library CVSS 3.1HIGH 7.5
- TI-2022-13116 Octokit gem published with world-writable files CVSS 3.1LOW 3.3
- TI-2022-13115 Octopoller gem published with world-writable files CVSS 3.1LOW 3.3
Sources
- CVE-2025-25288 · CVE Program
- CVE-2025-25288 · NVD
- FIRST EPSS
- GHSA-h5c3-5r3r-rr8q · GitHub Advisory Database · CC BY 4.0
- CVE-2025-25288 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences