A Server-Side Template Injection (SSTI) vulnerability in Spacy-LLM v0.7.2 allows…
Priority HIGH 82CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
A Server-Side Template Injection (SSTI) vulnerability in Spacy-LLM v0.7.2 allows attackers to execute arbitrary code via injecting a crafted payload into the template field.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00796 56th percentileScored 2026-11-07
Fix Fixed spacy-llm (PyPI): 0.7.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | spacy-llm (PyPI) | before 0.7.3 | 0.7.3 | Patch available | GHSA-793v-gxfp-9q9h |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- spacy-llm (PyPI) Vendor— Affected before 0.7.3 Fixed in 0.7.3 Patch available GHSA-793v-gxfp-9q9h
Remediation
- Fix · GHSA-793v-gxfp-9q9h spacy-llm (PyPI) Fixed in 0.7.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-25362
- 2026-10-03 Alias added: GHSA-793v-gxfp-9q9h
References
Other 6
- https://github.com/explosion/spacy-llm/issues/492
- https://www.hacktivesecurity.com/blog/2025/04/01/cve-2025-25362-old-vulnerabilities-new-victims-breaking-llm-prompts-with-ssti/
- https://github.com/explosion/spacy-llm/pull/491
- https://github.com/explosion/spacy-llm/commit/8bde0490cc1e9de9dd2e84480b7b5cd18a94d739
- https://github.com/explosion/spacy-llm
- https://www.hacktivesecurity.com/blog/2025/04/01/cve-2025-25362-old-vulnerabilities-new-victims-breaking-llm-prompts-with-ssti
Sources
- CVE-2025-25362 · CVE Program
- CVE-2025-25362 · NVD
- FIRST EPSS
- GHSA-793v-gxfp-9q9h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences