Read the docs
TI-2025-20004 Aliases CVE-2025-27147

GLPI Inventory plugin has Improper Access Control Vulnerability

Priority LOW 36CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-552.

Summary

The GLPI Inventory Plugin handles various types of tasks for GLPI agents, including network discovery and inventory (SNMP), software deployment, VMWare ESX host remote inventory, and data collection (files, Windows registry, WMI). Versions prior to 1.5.0 have an improper access control vulnerability. Version 1.5.0 fixes the vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00442 38th percentileScored 2026-11-07
Fix Fixed glpi-inventory-plugin (glpi-project): 1.5.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
glpi-projectglpi-inventory-pluginbefore 1.5.01.5.0Patch availableCNA
  • glpi-inventory-plugin Vendorglpi-project Affected before 1.5.0 Fixed in 1.5.0 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:glpi-project:glpi_inventory:*:*:*:*:*:*:*:*——glpi-project
  • cpe:2.3:a:glpi-project:glpi_inventory:*:*:*:*:*:*:*:* Versions — — ·glpi-project

Remediation

  • Fix · CNA glpi-inventory-plugin (glpi-project) Fixed in 1.5.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-27147

References

  • TI-2022-16341 /vendor/htmlawed/htmlawed/htmLawedTest.php in the htmlawed module for GLPI through 10.0.2 allows PHP code injection. KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-18516 GLPI allows unauthenticated SQL injection through the inventory endpoint CVSS 3.1CRITICAL 9.8
  • TI-2023-25210 GLPI SQL injection through inventory agent request CVSS 3.1CRITICAL 9.8
  • TI-2022-15054 The Cartography (aka positions) plugin before 6.0.1 for GLPI allows remote code execution… CVSS 3.1CRITICAL 9.8
  • TI-2023-17986 GLPI vulnerable to SQL injection via inventory agent request CVSS 3.1CRITICAL 9.8
  • TI-2022-13106 SQL injection on login page in GLPI CVSS 3.1CRITICAL 9.8
See all 237 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences