Cross-site scripting in Revive Adserver
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A reflected Cross-Site Scripting (XSS) vulnerability has been identified in Revive Adserver version 5.5.2. An attacker could trick a user with access to the user interface of a Revive Adserver instance into clicking on a specifically crafted URL and execute injected JavaScript code in the context of the victim's browser. The session cookie cannot be accessed, but a number of other operations could be performed. The vulnerability is present in the admin-search.php file and can be exploited via the compact parameter.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Revive | Revive Adserver | 5.5.2 – 5.5.2 | 6.0.0 | Patch available | CNA |
- Revive Adserver VendorRevive Affected 5.5.2 – 5.5.2 Fixed in 6.0.0 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:revive-adserver:revive_adserver:*:*:*:*:*:*:*:* | before 6.0.0 | Vulnerable | Revive Adserver |
| cpe:2.3:a:revive-adserver:revive_adserver:6.0.0:rc1:*:*:*:*:*:* | 6.0.0 rc1 | Vulnerable | Revive Adserver |
- cpe:2.3:a:revive-adserver:revive_adserver:*:*:*:*:*:*:*:* Versions before 6.0.0 Vulnerable ·Revive Adserver
- cpe:2.3:a:revive-adserver:revive_adserver:6.0.0:rc1:*:*:*:*:*:* Versions 6.0.0 rc1 Vulnerable ·Revive Adserver
Remediation
- Fix · CNA Revive Adserver (Revive) Fixed in 6.0.0
Timeline
- 2026-10-02 Threatist record created from CVE-2025-27208
- 2026-10-03 Alias added: GHSA-2hxf-5ppp-g398
References
More Revive vulnerabilities
- TI-2025-31114 Improper access control in Revive Adserver CVSS 3.0HIGH 8.8
- TI-2025-34810 Cross-site scripting in Revive Adserver CVSS 3.0MEDIUM 6.5
- TI-2022-04278 Revive Old Posts – Social Media Auto Post and Scheduling Plugin < 9.0.11 - PHP Object Injection CVSS 3.1HIGH 7.2
- TI-2023-11756 The login page of Revive Adserver v5.4.1 is vulnerable to brute force attacks. CVSS 3.1HIGH 7.5
- TI-2025-34812 Uncontrolled resource consumption in Revive Adserver CVSS 3.0MEDIUM 6.5
- TI-2025-32749 Missing authorization in Revive Adserver CVSS 3.1MEDIUM 6.5
Sources
- CVE-2025-27208 · CVE Program
- CVE-2025-27208 · NVD
- FIRST EPSS
- GHSA-2hxf-5ppp-g398 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences