Improper input validation in Ubiquiti UniFi Access Reader Pro
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-77.
Summary
An Improper Input Validation in certain UniFi Access devices could allow a Command Injection by a malicious actor with access to UniFi Access management network. Affected Products: UniFi Access Reader Pro (Version 2.14.21 and earlier) UniFi Access G2 Reader Pro (Version 1.10.32 and earlier) UniFi Access G3 Reader Pro (Version 1.10.30 and earlier) UniFi Access Intercom (Version 1.7.28 and earlier) UniFi Access G3 Intercom (Version 1.7.29 and earlier) UniFi Access Intercom Viewer (Version 1.3.20 and earlier) Mitigation: Update UniFi Access Reader Pro Version 2.15.9 or later Update UniFi Access G2 Reader Pro Version 1.11.23 or later Update UniFi Access G3 Reader Pro Version 1.11.22 or later Update UniFi Access Intercom Version 1.8.22 or later Update UniFi Access G3 Intercom Version 1.8.22 or later Update UniFi Access Intercom Viewer Version 1.4.39 or later
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Ubiquiti | UniFi Access Reader Pro | 2.15.9 to before 2.15.9 | 2.15.9 | Patch available | CNA |
| Ubiquiti | UniFi Access G2 Reader Pro | 1.11.23 to before 1.11.23 | 1.11.23 | Patch available | CNA |
| Ubiquiti | UniFi Access G3 Reader Pro | 1.11.22 to before 1.11.22 | 1.11.22 | Patch available | CNA |
| Ubiquiti | UniFi Access Intercom | 1.8.22 to before 1.8.22 | 1.8.22 | Patch available | CNA |
| Ubiquiti | UniFi Access G3 Intercom | 1.8.22 to before 1.8.22 | 1.8.22 | Patch available | CNA |
| Ubiquiti | UniFi Access Intercom Viewer | 1.4.39 to before 1.4.39 | 1.4.39 | Patch available | CNA |
- UniFi Access Reader Pro VendorUbiquiti Affected 2.15.9 to before 2.15.9 Fixed in 2.15.9 Patch available CNA
- UniFi Access G2 Reader Pro VendorUbiquiti Affected 1.11.23 to before 1.11.23 Fixed in 1.11.23 Patch available CNA
- UniFi Access G3 Reader Pro VendorUbiquiti Affected 1.11.22 to before 1.11.22 Fixed in 1.11.22 Patch available CNA
- UniFi Access Intercom VendorUbiquiti Affected 1.8.22 to before 1.8.22 Fixed in 1.8.22 Patch available CNA
- UniFi Access G3 Intercom VendorUbiquiti Affected 1.8.22 to before 1.8.22 Fixed in 1.8.22 Patch available CNA
- UniFi Access Intercom Viewer VendorUbiquiti Affected 1.4.39 to before 1.4.39 Fixed in 1.4.39 Patch available CNA
Remediation
- Fix · CNA UniFi Access Reader Pro (Ubiquiti Inc) Fixed in 2.15.9
- Fix · CNA UniFi Access G2 Reader Pro (Ubiquiti Inc) Fixed in 1.11.23
- Fix · CNA UniFi Access G3 Reader Pro (Ubiquiti Inc) Fixed in 1.11.22
- Fix · CNA UniFi Access Intercom (Ubiquiti Inc) Fixed in 1.8.22
- Fix · CNA UniFi Access G3 Intercom (Ubiquiti Inc) Fixed in 1.8.22
- Fix · CNA UniFi Access Intercom Viewer (Ubiquiti Inc) Fixed in 1.4.39
Timeline
- 2026-10-02 Threatist record created from CVE-2025-27212
- 2026-10-03 Alias added: GHSA-pr73-55xw-cpwc
References
More Ubiquiti vulnerabilities
- TI-2026-27142 Improper input validation in Ubiquiti UniFi OS Server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-27141 Path traversal in Ubiquiti UniFi OS Server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-27140 Improper access control in Ubiquiti UniFi OS Server KEVCVSS 3.1CRITICAL 10.0
- TI-2010-05027 On certain Ubiquiti devices, Command Injection exists via a GET request to stainfo.cgi… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-19187 AirControl 1.4.2 - PreAuth Remote Code Execution CVSS 4.0CRITICAL 9.3
- TI-2015-07644 Ubiquiti airOS HTTP(S) unauthenticated arbitrary file upload CVSS 3.0CRITICAL 9.8
Sources
- CVE-2025-27212 · CVE Program
- CVE-2025-27212 · NVD
- FIRST EPSS
- GHSA-pr73-55xw-cpwc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences