Information disclosure in ruby URI
Priority LOW 25CWE-212Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 4 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.
Summary
In the URI gem before 1.0.3 for Ruby, the URI handling methods (URI.join, URI#merge, URI#+) have an inadvertent leakage of authentication credentials because userinfo is retained even after changing the host.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00511 43rd percentileScored 2026-11-07
Fix Partial URI (ruby-lang): 0.11.3, 0.12.4, 0.13.2 +1uri (RubyGems): 0.11.3, 0.12.4, 0.13.2 +1Red Hat: 5 advisoriesRed Hat: 4 fixed, 1 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ruby | URI | before 0.11.3; 0.12.0 to before 0.12.4; 0.13.0 to before 0.13.2; 1.0.0 to before 1.0.3 | 0.11.3, 0.12.4, 0.13.2, 1.0.3 | Patch available | CNA |
| — | uri (RubyGems) | before 0.11.3 | 0.11.3 | Patch available | GHSA-22h5-pq3x-2gf2 |
| — | uri (RubyGems) | 0.12.0 to before 0.12.4 | 0.12.4 | Patch available | GHSA-22h5-pq3x-2gf2 |
| — | uri (RubyGems) | 0.13.0 to before 0.13.2 | 0.13.2 | Patch available | GHSA-22h5-pq3x-2gf2 |
| — | uri (RubyGems) | 1.0.0 to before 1.0.3 | 1.0.3 | Patch available | GHSA-22h5-pq3x-2gf2 |
- URI Vendorruby Affected before 0.11.3; 0.12.0 to before 0.12.4; 0.13.0 to before 0.13.2; 1.0.0 to before 1.0.3 Fixed in 0.11.3, 0.12.4, 0.13.2, 1.0.3 Patch available CNA
- uri (RubyGems) Vendor— Affected before 0.11.3 Fixed in 0.11.3 Patch available GHSA-22h5-pq3x-2gf2
- uri (RubyGems) Vendor— Affected 0.12.0 to before 0.12.4 Fixed in 0.12.4 Patch available GHSA-22h5-pq3x-2gf2
- uri (RubyGems) Vendor— Affected 0.13.0 to before 0.13.2 Fixed in 0.13.2 Patch available GHSA-22h5-pq3x-2gf2
- uri (RubyGems) Vendor— Affected 1.0.0 to before 1.0.3 Fixed in 1.0.3 Patch available GHSA-22h5-pq3x-2gf2
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ruby-lang:uri:*:*:*:*:*:ruby:*:* | before 0.11.3; 0.12.0 to before 0.12.4; 0.13.0 to before 0.13.2; 1.0.0 to before 1.0.3 | Vulnerable | ruby |
- cpe:2.3:a:ruby-lang:uri:*:*:*:*:*:ruby:*:* Versions before 0.11.3; 0.12.0 to before 0.12.4; 0.13.0 to before 0.13.2; 1.0.0 to before 1.0.3 Vulnerable ·ruby
Remediation
- Fix · CNA URI (ruby-lang) Fixed in 0.11.3, 0.12.4, 0.13.2, 1.0.3
- Fix · GHSA-22h5-pq3x-2gf2 uri (RubyGems) Fixed in 0.11.3 Advisory →
- Fix · GHSA-22h5-pq3x-2gf2 uri (RubyGems) Fixed in 0.12.4 Advisory →
- Fix · GHSA-22h5-pq3x-2gf2 uri (RubyGems) Fixed in 0.13.2 Advisory →
- Fix · GHSA-22h5-pq3x-2gf2 uri (RubyGems) Fixed in 1.0.3 Advisory →
Red Hat 5 advisories
- RHSA-2025:10217 Released 2025-07-02 · Red Hat rating Moderateruby:3.3 security update
- Red Hat Enterprise Linux AppStream (v. 8) ruby-3.3.8-4.module+el8.10.0+23024+a87ba659.aarch64::ruby:3.3, ruby-3.3.8-4.module+el8.10.0+23024+a87ba659.i686::ruby:3.3, ruby-3.3.8-4.module+el8.10.0+23024+a87ba659.ppc64le::ruby:3.3 +47
- RHSA-2025:8131 Released 2025-05-26 · Red Hat rating Moderateruby security update
- Red Hat Enterprise Linux AppStream (v. 10) ruby-3.3.8-10.el10_0, ruby-bundled-gems-3.3.8-10.el10_0, ruby-default-gems-3.3.8-10.el10_0 +20
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) ruby-doc-3.3.8-10.el10_0
- RHSA-2025:4493 Released 2025-05-06 · Red Hat rating Moderateruby:3.3 security update
- Red Hat Enterprise Linux AppStream (v. 9) ruby-3.3.8-4.module+el9.5.0+23030+26c9b8e1.aarch64::ruby:3.3, ruby-3.3.8-4.module+el9.5.0+23030+26c9b8e1.i686::ruby:3.3, ruby-3.3.8-4.module+el9.5.0+23030+26c9b8e1.ppc64le::ruby:3.3 +47
Show 2 more Red Hat advisories
- RHSA-2025:4488 Released 2025-05-06 · Red Hat rating Moderateruby:3.1 security update
- Red Hat Enterprise Linux AppStream (v. 9) ruby-3.1.7-146.module+el9.5.0+23003+a4c328ce.aarch64::ruby:3.1, ruby-3.1.7-146.module+el9.5.0+23003+a4c328ce.i686::ruby:3.1, ruby-3.1.7-146.module+el9.5.0+23003+a4c328ce.ppc64le::ruby:3.1 +47
- RHSA-2025:4063 Released 2025-04-23 · Red Hat rating Moderateruby:3.1 security update
- Red Hat Enterprise Linux AppStream (v. 8) ruby-3.1.7-145.module+el8.10.0+23011+f9d508f8.aarch64::ruby:3.1, ruby-3.1.7-145.module+el8.10.0+23011+f9d508f8.i686::ruby:3.1, ruby-3.1.7-145.module+el8.10.0+23011+f9d508f8.ppc64le::ruby:3.1 +47
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AppStream (v. 10) | Fixed | RHSA-2025:8131 |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2025:10217, RHSA-2025:4063 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2025:4488, RHSA-2025:4493 |
| Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) | Fixed | RHSA-2025:8131 |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-27221
- 2026-10-03 Alias added: GHSA-22h5-pq3x-2gf2
References
Advisory 2
Other 10
- https://hackerone.com/reports/2957667
- https://github.com/ruby/uri/pull/154
- https://github.com/ruby/uri/pull/155
- https://github.com/ruby/uri/pull/156
- https://github.com/ruby/uri/pull/157
- https://github.com/ruby/uri
- https://lists.debian.org/debian-lts-announce/2025/03/msg00008.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00015.html
- https://www.cve.org/CVERecord?id=CVE-2025-27221
- https://www.ruby-lang.org/en/news/2025/02/26/security-advisories
More ruby Uri vulnerabilities
- TI-2023-13266 A ReDoS issue was discovered in the URI component through 0.12.0 in Ruby through 3.2.1. CVSS 3.1MEDIUM 5.3
- TI-2023-18437 A ReDoS issue was discovered in the URI component before 0.12.2 for Ruby. CVSS 3.1MEDIUM 5.3
- TI-2025-38040 URI Credential Leakage Bypass over CVE-2025-27221 CVSS 4.0LOW 2.1
Sources
- CVE-2025-27221 · CVE Program
- CVE-2025-27221 · NVD
- FIRST EPSS
- GHSA-22h5-pq3x-2gf2 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-27221 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences