Magento vulnerable to stored XSS in theme config fields
Key facts
- Attack vector
- Adjacent network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Versions prior to 20.12.3 and 20.13.0 contain a vulnerability that allows script execution in the admin panel which could lead to cross-site scripting against authenticated admin users. The attack requires an admin user with configuration access, so in practicality it is not very likely to be useful given that a user with this level of access is probably already a full admin. Versions 20.12.3 and 20.13.0 contain a patch for the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenMage | magento-lts | before 20.12.3 | 20.12.3 | Patch available | CNA |
| — | openmage/magento-lts (Packagist) | before 20.12.3 | 20.12.3 | Patch available | GHSA-5pxh-89cx-4668 |
- magento-lts VendorOpenMage Affected before 20.12.3 Fixed in 20.12.3 Patch available CNA
- openmage/magento-lts (Packagist) Vendor— Affected before 20.12.3 Fixed in 20.12.3 Patch available GHSA-5pxh-89cx-4668
Remediation
- Fix · CNA magento-lts (OpenMage) Fixed in 20.12.3
- Fix · GHSA-5pxh-89cx-4668 openmage/magento-lts (Packagist) Fixed in 20.12.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-27400
- 2026-10-03 Alias added: GHSA-5pxh-89cx-4668
References
Other 5
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-5pxh-89cx-4668
- https://github.com/OpenMage/magento-lts/commit/d307e5bf75729a2347dde0952fe9fd9fcd9c6aea
- https://github.com/OpenMage/magento-lts/releases/tag/v20.12.3
- https://github.com/OpenMage/magento-lts/releases/tag/v20.13.0
- https://github.com/OpenMage/magento-lts
More OpenMage vulnerabilities
- TI-2026-30484 Magento LTS: Weak API Session ID — Predictable MD5 of Time-Derived Inputs CVSS 4.0CRITICAL 9.3
- TI-2026-20633 OpenMage LTS's Phar Deserialization leads to Remote Code Execution CVSS 3.1HIGH 8.1
- TI-2026-29239 OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution CVSS 4.0HIGH 8.7
- TI-2023-22272 Magento LTS's guest order "protect code" can be brute-forced too easily CVSS 3.1HIGH 7.5
- TI-2026-30528 Magento LTS: Open Redirect via Unvalidated `uenc` Parameter in `stockAction()` - magento-lts CVSS 3.1MEDIUM 6.1
- TI-2026-30747 Magento LTS: Reflected XSS - Import -> Data Flow (profiles) CVSS 4.0MEDIUM 5.3
Sources
- CVE-2025-27400 · CVE Program
- CVE-2025-27400 · NVD
- FIRST EPSS
- GHSA-5pxh-89cx-4668 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences