Resource allocation without limits in djangoproject Django
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-770.
Summary
An issue was discovered in Django 5.1 before 5.1.8 and 5.0 before 5.0.14. The NFKC normalization is slow on Windows. As a consequence, django.contrib.auth.views.LoginView, django.contrib.auth.views.LogoutView, and django.views.i18n.set_language are subject to a potential denial-of-service attack via certain inputs with a very large number of Unicode characters.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| djangoproject | Django | 5.0 to before 5.0.14; 5.1 to before 5.1.8 | 5.0.14, 5.1.8 | Patch available | CNA |
| — | Django (PyPI) | 5.0 to before 5.0.14 | 5.0.14 | Patch available | GHSA-wqfg-m96j-85vm |
| — | Django (PyPI) | 5.1 to before 5.1.8 | 5.1.8 | Patch available | GHSA-wqfg-m96j-85vm |
- Django Vendordjangoproject Affected 5.0 to before 5.0.14; 5.1 to before 5.1.8 Fixed in 5.0.14, 5.1.8 Patch available CNA
- Django (PyPI) Vendor— Affected 5.0 to before 5.0.14 Fixed in 5.0.14 Patch available GHSA-wqfg-m96j-85vm
- Django (PyPI) Vendor— Affected 5.1 to before 5.1.8 Fixed in 5.1.8 Patch available GHSA-wqfg-m96j-85vm
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | 5.0 to before 5.0.14; 5.1 to before 5.1.8 | Vulnerable | djangoproject |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions 5.0 to before 5.0.14; 5.1 to before 5.1.8 Vulnerable ·djangoproject
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
Remediation
- Fix · CNA Django (djangoproject) Fixed in 5.0.14, 5.1.8
- Fix · GHSA-wqfg-m96j-85vm Django (PyPI) Fixed in 5.0.14 Advisory →
- Fix · GHSA-wqfg-m96j-85vm Django (PyPI) Fixed in 5.1.8 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat Ansible Automation Platform 2
- Red Hat Discovery 1
Timeline
- 2026-10-02 Threatist record created from CVE-2025-27556
- 2026-10-03 Alias added: GHSA-wqfg-m96j-85vm
References
Advisory 5
Other 8
- https://github.com/django/django/commit/2cb311f7b069723027fb5def4044d1816d7d2afd
- https://github.com/django/django/commit/39e2297210d9d2938c75fc911d45f0e863dc4821
- https://github.com/django/django/commit/8c6871b097b6c49d2a782c0d80d908bcbe2116f1
- https://github.com/django/django/commit/edc2716d01a6fdd84b173c02031695231bcee1f8
- https://docs.djangoproject.com/en/dev/releases/security
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2025-14.yaml
- https://www.djangoproject.com/weblog/2025/apr/02/security-releases
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-27556 · CVE Program
- CVE-2025-27556 · NVD
- FIRST EPSS
- GHSA-wqfg-m96j-85vm · GitHub Advisory Database · CC BY 4.0
- CVE-2025-27556 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences