Read the docs
TI-2025-20416 Aliases CVE-2025-27607

Python JSON Logger has a Potential RCE via missing `msgspec-python313-pre` dependency

Priority HIGH 73CWE-829Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-829.

Summary

Python JSON Logger is a JSON Formatter for Python Logging. Between 30 December 2024 and 4 March 2025 Python JSON Logger was vulnerable to RCE through a missing dependency. This occurred because msgspec-python313-pre was deleted by the owner leaving the name open to being claimed by a third party. If the package was claimed, it would allow them RCE on any Python JSON Logger user who installed the development dependencies on Python 3.13 (e.g. pip install python-json-logger[dev]). This issue has been resolved with 3.3.0.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01609 76th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed python-json-logger (nhairs): 3.3.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
nhairspython-json-logger3.2.0 to before 3.3.03.3.0Patch availableCNA
  • python-json-logger Vendornhairs Affected 3.2.0 to before 3.3.0 Fixed in 3.3.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:nhairs:python_json_logger:*:*:*:*:*:*:*:*before 3.3.0Vulnerablenhairs
  • cpe:2.3:a:nhairs:python_json_logger:*:*:*:*:*:*:*:* Versions before 3.3.0 Vulnerable ·nhairs

Remediation

  • Fix · CNA python-json-logger (nhairs) Fixed in 3.3.0

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

Not affected: 2 products
  • Red Hat OpenStack Platform 16.2
  • Red Hat OpenStack Platform 17.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-27607

References

Sources