Apache Felix HTTP Webconsole Plugin: XSS in HTTP Webconsole Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Felix HTTP Webconsole Plugin. This issue affects Apache Felix HTTP Webconsole Plugin: from Version 1.X through 1.2.0. Users are recommended to upgrade to version 1.2.2, which fixes the issue.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00571 47th percentileScored 2026-11-07
Fix Fixed org.apache.felix:org.apache.felix.http.webconsoleplugin (Maven): 1.2.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Felix HTTP Webconsole Plugin | 1.x – 1.2.0 | — | No fix listed | CNA |
| — | org.apache.felix:org.apache.felix.http.webconsoleplugin (Maven) | before 1.2.2 | 1.2.2 | Patch available | GHSA-2cv6-4f2r-jq2c |
- Apache Felix HTTP Webconsole Plugin VendorApache Affected 1.x – 1.2.0 Fixed in — No fix listed CNA
- org.apache.felix:org.apache.felix.http.webconsoleplugin (Maven) Vendor— Affected before 1.2.2 Fixed in 1.2.2 Patch available GHSA-2cv6-4f2r-jq2c
Remediation
- Fix · GHSA-2cv6-4f2r-jq2c org.apache.felix:org.apache.felix.http.webconsoleplugin (Maven) Fixed in 1.2.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-27867
- 2026-10-03 Alias added: GHSA-2cv6-4f2r-jq2c
References
Sources
- CVE-2025-27867 · CVE Program
- CVE-2025-27867 · NVD
- FIRST EPSS
- GHSA-2cv6-4f2r-jq2c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences