An integer overflow in Nethermind Juno before v.12.05 within the Sierra bytecode…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-190 and the CVSS impact.
Summary
An integer overflow in Nethermind Juno before v.12.05 within the Sierra bytecode decompression logic within the "cairo-lang-starknet-classes" library could allow remote attackers to trigger an infinite loop (and high CPU usage) by submitting a malicious Declare v2/v3 transaction. This results in a denial-of-service condition for affected Starknet full-node implementations.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/NethermindEth/juno (Go) | before 0.12.5 | 0.12.5 | Patch available | GHSA-wq32-8rp4-w2mc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/NethermindEth/juno (Go) Vendor— Affected before 0.12.5 Fixed in 0.12.5 Patch available GHSA-wq32-8rp4-w2mc
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nethermind:juno:*:*:*:*:*:*:*:* | before 0.12.5 | Vulnerable | Nethermind |
- cpe:2.3:a:nethermind:juno:*:*:*:*:*:*:*:* Versions before 0.12.5 Vulnerable ·Nethermind
Remediation
- Fix · GHSA-wq32-8rp4-w2mc github.com/NethermindEth/juno (Go) Fixed in 0.12.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-29072
- 2026-10-03 Alias added: GHSA-wq32-8rp4-w2mc
References
Advisory 2
Sources
- CVE-2025-29072 · CVE Program
- CVE-2025-29072 · NVD
- FIRST EPSS
- GHSA-wq32-8rp4-w2mc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences