pg-promise before 11.5.5 is vulnerable to SQL Injection due to improper handling of negative numbers.
Priority HIGH 66CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
pg-promise before 11.5.5 is vulnerable to SQL Injection due to improper handling of negative numbers.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00221 12th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed pg-promise (npm): 11.5.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | pg-promise (npm) | before 11.5.5 | 11.5.5 | Patch available | GHSA-ff9h-848c-4xfj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- pg-promise (npm) Vendor— Affected before 11.5.5 Fixed in 11.5.5 Patch available GHSA-ff9h-848c-4xfj
Remediation
- Fix · GHSA-ff9h-848c-4xfj pg-promise (npm) Fixed in 11.5.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-29744
- 2026-10-03 Alias added: GHSA-ff9h-848c-4xfj
References
Exploit 2
Sources
- CVE-2025-29744 · CVE Program
- CVE-2025-29744 · NVD
- FIRST EPSS
- GHSA-ff9h-848c-4xfj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences