QuRouter 2.5
Priority LOW 35CWE-77Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Active
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-77.
Summary
A command injection vulnerability has been reported to affect QuRouter 2.5.1. If a remote attacker gains an administrator account, they can then exploit the vulnerability to execute arbitrary commands. We have already fixed the vulnerability in the following version: QuRouter 2.5.1.060 and later
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00839 58th percentileScored 2026-11-07
Fix Fixed QuRouter (QNAP Systems Inc.): 2.5.1.060
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| QNAP | QuRouter | 2.5.x to before 2.5.1.060 | 2.5.1.060 | Patch available | CNA |
- QuRouter VendorQNAP Affected 2.5.x to before 2.5.1.060 Fixed in 2.5.1.060 Patch available CNA
Remediation
- Fix · CNA QuRouter (QNAP Systems Inc.) Fixed in 2.5.1.060
Timeline
- 2026-10-02 Threatist record created from CVE-2025-29887
- 2026-10-03 Alias added: GHSA-423r-mv6p-g8cm
References
More QNAP Qurouter vulnerabilities
- TI-2024-32560 Command injection in QNAP QuRouter CVSS 4.0CRITICAL 9.5
- TI-2024-33824 SQL injection in QNAP QuRouter CVSS 4.0CRITICAL 9.5
- TI-2024-33825 OS command injection in QNAP QuRouter CVSS 4.0HIGH 7.7
- TI-2024-32561 Command injection in QNAP QuRouter CVSS 4.0HIGH 7.3
- TI-2025-38999 SQL injection in QNAP QuRouter CVSS 4.0HIGH 7.3
- TI-2024-35898 Command injection in QNAP QuRouter CVSS 4.0MEDIUM 5.1
Sources
- CVE-2025-29887 · CVE Program
- CVE-2025-29887 · NVD
- FIRST EPSS
- GHSA-423r-mv6p-g8cm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences