XWiki uses the wrong wiki reference in AuthorizationManager
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Privilege escalation, Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-269 and CWE-863.
Summary
XWiki Platform is a generic wiki platform. Prior to 15.10.14, 16.4.6, and 16.10.0-rc-1, it's possible for an user to get access to private information through the REST API - but could also be through another API - when a sub wiki is using "Prevent unregistered users to view pages". The vulnerability only affects subwikis, and it only concerns specific right options such as "Prevent unregistered users to view pages". or "Prevent unregistered users to edit pages". It's possible to detect the vulnerability by enabling "Prevent unregistered users to view pages" and then trying to access a page through the REST API without using any credentials. The vulnerability has been patched in XWiki 15.10.14, 16.4.6 and 16.10.0RC1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| XWiki | xwiki-platform | 6.1-rc-1 to before 15.10.14; 16.0.0-rc-1 to before 16.4.6; 16.5.0-rc-1 to before 16.10.0-rc-1 | 15.10.14, 16.4.6, 16.10.0-rc-1 | Patch available | CNA |
| — | org.xwiki.platform:xwiki-platform-security-authorization-api (Maven) | 6.1-rc-1 to before 15.10.14 | 15.10.14 | Patch available | GHSA-gq32-758c-3wm3 |
| — | org.xwiki.platform:xwiki-platform-security-authorization-api (Maven) | 16.0.0-rc-1 to before 16.4.6 | 16.4.6 | Patch available | GHSA-gq32-758c-3wm3 |
| — | org.xwiki.platform:xwiki-platform-security-authorization-api (Maven) | 16.5.0-rc-1 to before 16.10.0-rc-1 | 16.10.0-rc-1 | Patch available | GHSA-gq32-758c-3wm3 |
- xwiki-platform VendorXWiki Affected 6.1-rc-1 to before 15.10.14; 16.0.0-rc-1 to before 16.4.6; 16.5.0-rc-1 to before 16.10.0-rc-1 Fixed in 15.10.14, 16.4.6, 16.10.0-rc-1 Patch available CNA
- org.xwiki.platform:xwiki-platform-security-authorization-api (Maven) Vendor— Affected 6.1-rc-1 to before 15.10.14 Fixed in 15.10.14 Patch available GHSA-gq32-758c-3wm3
- org.xwiki.platform:xwiki-platform-security-authorization-api (Maven) Vendor— Affected 16.0.0-rc-1 to before 16.4.6 Fixed in 16.4.6 Patch available GHSA-gq32-758c-3wm3
- org.xwiki.platform:xwiki-platform-security-authorization-api (Maven) Vendor— Affected 16.5.0-rc-1 to before 16.10.0-rc-1 Fixed in 16.10.0-rc-1 Patch available GHSA-gq32-758c-3wm3
Remediation
- Fix · CNA xwiki-platform (xwiki) Fixed in 15.10.14, 16.4.6, 16.10.0-rc-1
- Fix · GHSA-gq32-758c-3wm3 org.xwiki.platform:xwiki-platform-security-authorization-api (Maven) Fixed in 15.10.14 Advisory →
- Fix · GHSA-gq32-758c-3wm3 org.xwiki.platform:xwiki-platform-security-authorization-api (Maven) Fixed in 16.4.6 Advisory →
- Fix · GHSA-gq32-758c-3wm3 org.xwiki.platform:xwiki-platform-security-authorization-api (Maven) Fixed in 16.10.0-rc-1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-29924
- 2026-10-03 Alias added: GHSA-gq32-758c-3wm3
References
Advisory 3
More Xwiki vulnerabilities
- TI-2025-18595 Remote code execution as guest via SolrSearchMacros request in xwiki KEVCVSS 3.1CRITICAL 9.8
- TI-2023-25214 Remote code execution through the section parameter in Administration as guest in XWiki Platform CVSS 3.1CRITICAL 10.0
- TI-2025-23500 XWiki Platform vulnerable to SQL injection through getdeleteddocuments.vm template sort parameter CVSS 4.0CRITICAL 9.3
- TI-2025-23979 org.xwiki.platform:xwiki-platform-rest-server allows SQL injection in query endpoint of REST API CVSS 4.0CRITICAL 9.3
- TI-2024-20829 XWiki Platform: Remote code execution from account via SearchSuggestSourceSheet CVSS 3.1CRITICAL 10.0
- TI-2024-14375 XWiki Remote Code Execution vulnerability via user registration CVSS 3.1CRITICAL 10.0
Sources
- CVE-2025-29924 · CVE Program
- CVE-2025-29924 · NVD
- FIRST EPSS
- GHSA-gq32-758c-3wm3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences