Kirby vulnerable to path traversal of snippet names in the `snippet()` helper
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
Kirby is an open-source content management system. A vulnerability in versions prior to 3.9.8.3, 3.10.1.2, and 4.7.1 affects all Kirby sites that use the `snippet()` helper or `$kirby->snippet()` method with a dynamic snippet name (such as a snippet name that depends on request or user data). Sites that only use fixed calls to the `snippet()` helper/`$kirby->snippet()` method (i.e. calls with a simple string for the snippet name) are *not* affected. A missing path traversal check allowed attackers to navigate and access all files on the server that were accessible to the PHP process, including files outside of the snippets root or even outside of the Kirby installation. PHP code within such files was executed. Such attacks first require an attack vector in the site code that is caused by dynamic snippet names, such as `snippet('tags-' . get('tags'))`. It generally also requires knowledge of the site structure and the server's file system by the attacker, although it can be possible to find vulnerable setups through automated methods such as fuzzing. In a vulnerable setup, this could cause damage to the confidentiality and integrity of the server. The problem has been patched in Kirby 3.9.8.3, Kirby 3.10.1.2, and Kirby 4.7.1. In all of the mentioned releases, Kirby maintainers have added a check for the snippet path that ensures that the resulting path is contained within the configured snippets root. Snippet paths that point outside of the snippets root will not be loaded.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getkirby | kirby | before 3.9.8.3; 3.10.0 to before 3.10.1.2; 4.0.0 to before 4.7.1 | 3.9.8.3, 3.10.1.2, 4.7.1 | Patch available | CNA |
| — | getkirby/kirby (Packagist) | before 3.9.8.3 | 3.9.8.3 | Patch available | GHSA-fw82-87p8-v6hp |
| — | getkirby/kirby (Packagist) | 3.10.0 to before 3.10.1.2 | 3.10.1.2 | Patch available | GHSA-fw82-87p8-v6hp |
| — | getkirby/kirby (Packagist) | 4.0.0 to before 4.7.1 | 4.7.1 | Patch available | GHSA-fw82-87p8-v6hp |
- kirby Vendorgetkirby Affected before 3.9.8.3; 3.10.0 to before 3.10.1.2; 4.0.0 to before 4.7.1 Fixed in 3.9.8.3, 3.10.1.2, 4.7.1 Patch available CNA
- getkirby/kirby (Packagist) Vendor— Affected before 3.9.8.3 Fixed in 3.9.8.3 Patch available GHSA-fw82-87p8-v6hp
- getkirby/kirby (Packagist) Vendor— Affected 3.10.0 to before 3.10.1.2 Fixed in 3.10.1.2 Patch available GHSA-fw82-87p8-v6hp
- getkirby/kirby (Packagist) Vendor— Affected 4.0.0 to before 4.7.1 Fixed in 4.7.1 Patch available GHSA-fw82-87p8-v6hp
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:* | before 3.9.8.3; 3.10.0 to before 3.10.1.2; 4.0.0 to before 4.7.1 | Vulnerable | getkirby |
- cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:* Versions before 3.9.8.3; 3.10.0 to before 3.10.1.2; 4.0.0 to before 4.7.1 Vulnerable ·getkirby
Remediation
- Fix · CNA kirby (getkirby) Fixed in 3.9.8.3, 3.10.1.2, 4.7.1
- Fix · GHSA-fw82-87p8-v6hp getkirby/kirby (Packagist) Fixed in 3.9.8.3 Advisory →
- Fix · GHSA-fw82-87p8-v6hp getkirby/kirby (Packagist) Fixed in 3.10.1.2 Advisory →
- Fix · GHSA-fw82-87p8-v6hp getkirby/kirby (Packagist) Fixed in 4.7.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-30159
- 2026-10-03 Alias added: GHSA-fw82-87p8-v6hp
References
More getkirby Kirby vulnerabilities
- TI-2024-17440 An arbitrary file upload vulnerability in the Profile Image module of Kirby CMS v4.1.0… CVSS 3.1HIGH 8.8
- TI-2024-17439 An HTML injection vulnerability exists in the Edit Content Layout module of Kirby CMS… CVSS 3.1HIGH 7.1
- TI-2026-23396 Kirby CMS through 5.1.4 allows an authenticated user with 'Editor' permissions to cause a… CVSS 3.1MEDIUM 6.5
- TI-2024-17441 A stored cross-site scripting (XSS) vulnerability in the Edit Content Layout module of… CVSS 3.1MEDIUM 6.1
- TI-2018-10413 An issue was discovered in Kirby 2.5.12. CVSS 3.1MEDIUM 5.4
- TI-2024-17438 Kirby CMS v4.1.0 was discovered to contain a reflected self-XSS vulnerability via the URL parameter. CVSS 3.1MEDIUM 4.7
Sources
- CVE-2025-30159 · CVE Program
- CVE-2025-30159 · NVD
- FIRST EPSS
- GHSA-fw82-87p8-v6hp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences