Kirby vulnerable to path traversal in the router for PHP's built-in server
Key facts
- Attack vector
- Adjacent network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
Kirby is an open-source content management system. A vulnerability in versions prior to 3.9.8.3, 3.10.1.2, and 4.7.1 affects all Kirby setups that use PHP's built-in server. Such setups are commonly only used during local development. Sites that use other server software (such as Apache, nginx or Caddy) are not affected. A missing path traversal check allowed attackers to navigate all files on the server that were accessible to the PHP process, including files outside of the Kirby installation. The vulnerable implementation delegated all existing files to PHP, including existing files outside of the document root. This leads to a different response that allows attackers to determine whether the requested file exists. Because Kirby's router only delegates such requests to PHP and does not load or execute them, contents of the files were not exposed as PHP treats requests to files outside of the document root as invalid. The problem has been patched in Kirby 3.9.8.3, Kirby 3.10.1.2, and Kirby 4.7.1. In all of the mentioned releases, the maintainers of Kirby have updated the router to check if existing static files are within the document root. Requests to files outside the document root are treated as page requests of the error page and will no longer allow to determine whether the file exists or not.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getkirby | kirby | before 3.9.8.3; 3.10.0 to before 3.10.1.2; 4.0.0 to before 4.7.1 | 3.9.8.3, 3.10.1.2, 4.7.1 | Patch available | CNA |
| — | getkirby/cms (Packagist) | before 3.9.8.3 | 3.9.8.3 | Patch available | GHSA-9p3p-w5jf-8xxg |
| — | getkirby/cms (Packagist) | 3.10.0 to before 3.10.1.2 | 3.10.1.2 | Patch available | GHSA-9p3p-w5jf-8xxg |
| — | getkirby/cms (Packagist) | 4.0.0 to before 4.7.1 | 4.7.1 | Patch available | GHSA-9p3p-w5jf-8xxg |
- kirby Vendorgetkirby Affected before 3.9.8.3; 3.10.0 to before 3.10.1.2; 4.0.0 to before 4.7.1 Fixed in 3.9.8.3, 3.10.1.2, 4.7.1 Patch available CNA
- getkirby/cms (Packagist) Vendor— Affected before 3.9.8.3 Fixed in 3.9.8.3 Patch available GHSA-9p3p-w5jf-8xxg
- getkirby/cms (Packagist) Vendor— Affected 3.10.0 to before 3.10.1.2 Fixed in 3.10.1.2 Patch available GHSA-9p3p-w5jf-8xxg
- getkirby/cms (Packagist) Vendor— Affected 4.0.0 to before 4.7.1 Fixed in 4.7.1 Patch available GHSA-9p3p-w5jf-8xxg
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:* | before 3.9.8.3; 3.10.0 to before 3.10.1.2; 4.0.0 to before 4.7.1 | Vulnerable | getkirby |
- cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:* Versions before 3.9.8.3; 3.10.0 to before 3.10.1.2; 4.0.0 to before 4.7.1 Vulnerable ·getkirby
Remediation
- Fix · CNA kirby (getkirby) Fixed in 3.9.8.3, 3.10.1.2, 4.7.1
- Fix · GHSA-9p3p-w5jf-8xxg getkirby/cms (Packagist) Fixed in 3.9.8.3 Advisory →
- Fix · GHSA-9p3p-w5jf-8xxg getkirby/cms (Packagist) Fixed in 3.10.1.2 Advisory →
- Fix · GHSA-9p3p-w5jf-8xxg getkirby/cms (Packagist) Fixed in 4.7.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-30207
- 2026-10-03 Alias added: GHSA-9p3p-w5jf-8xxg
References
Advisory 2
More getkirby Kirby vulnerabilities
- TI-2024-17440 An arbitrary file upload vulnerability in the Profile Image module of Kirby CMS v4.1.0… CVSS 3.1HIGH 8.8
- TI-2024-17439 An HTML injection vulnerability exists in the Edit Content Layout module of Kirby CMS… CVSS 3.1HIGH 7.1
- TI-2026-23396 Kirby CMS through 5.1.4 allows an authenticated user with 'Editor' permissions to cause a… CVSS 3.1MEDIUM 6.5
- TI-2024-17441 A stored cross-site scripting (XSS) vulnerability in the Edit Content Layout module of… CVSS 3.1MEDIUM 6.1
- TI-2018-10413 An issue was discovered in Kirby 2.5.12. CVSS 3.1MEDIUM 5.4
- TI-2024-17438 Kirby CMS v4.1.0 was discovered to contain a reflected self-XSS vulnerability via the URL parameter. CVSS 3.1MEDIUM 4.7
Sources
- CVE-2025-30207 · CVE Program
- CVE-2025-30207 · NVD
- FIRST EPSS
- GHSA-9p3p-w5jf-8xxg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences