Read the docs
TI-2025-21548 Aliases CVE-2025-30212GHSA-3hj6-r5c9-q8f3

Frappe has possibility of SQL injection due to improper validations

Priority LOW 36CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
SQL injection
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

Frappe is a full-stack web application framework. An SQL Injection vulnerability has been identified in Frappe Framework prior to versions 14.89.0 and 15.51.0 which could allow a malicious actor to access sensitive information. Versions 14.89.0 and 15.51.0 fix the issue. Upgrading is required; no other workaround is present.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00442 38th percentileScored 2026-11-07
Fix Fixed frappe (frappe): 14.89.0, 15.51.0frappe (PyPI): 14.89.0, 15.51.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
frappefrappebefore 14.89.0; 15.0.0 to before 15.51.014.89.0, 15.51.0Patch availableCNA
—frappe (PyPI)before 14.89.014.89.0Patch availableGHSA-3hj6-r5c9-q8f3
—frappe (PyPI)15.0.0 to before 15.51.015.51.0Patch availableGHSA-3hj6-r5c9-q8f3
  • frappe Vendorfrappe Affected before 14.89.0; 15.0.0 to before 15.51.0 Fixed in 14.89.0, 15.51.0 Patch available CNA
  • frappe (PyPI) Vendor— Affected before 14.89.0 Fixed in 14.89.0 Patch available GHSA-3hj6-r5c9-q8f3
  • frappe (PyPI) Vendor— Affected 15.0.0 to before 15.51.0 Fixed in 15.51.0 Patch available GHSA-3hj6-r5c9-q8f3

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:frappe:frappe:*:*:*:*:*:*:*:*before 14.89.0; 15.0.0 to before 15.51.0Vulnerablefrappe
  • cpe:2.3:a:frappe:frappe:*:*:*:*:*:*:*:* Versions before 14.89.0; 15.0.0 to before 15.51.0 Vulnerable ·frappe

Remediation

  • Fix · CNA frappe (frappe) Fixed in 14.89.0, 15.51.0
  • Fix · GHSA-3hj6-r5c9-q8f3 frappe (PyPI) Fixed in 14.89.0 Advisory →
  • Fix · GHSA-3hj6-r5c9-q8f3 frappe (PyPI) Fixed in 15.51.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-30212
  2. 2026-10-03 Alias added: GHSA-3hj6-r5c9-q8f3

References

  • TI-2025-35319 ERPNEXT v15.67.0 was discovered to contain multiple SQL injection vulnerabilities in the… CVSS 3.1MEDIUM 6.5
  • TI-2025-35318 Frappe Framework v15.72.4 was discovered to contain a SQL injection vulnerability via the… CVSS 3.1MEDIUM 6.5
  • TI-2022-20104 Path traversal in Frappe CVSS 3.1MEDIUM 6.5
  • TI-2025-35317 A stored cross-site scripting (XSS) vulnerability in the blog post feature of ERPNEXT… CVSS 3.1MEDIUM 5.4
  • TI-2026-03168 Frappe Framework 16.10.0 - Stored DOM XSS in Tag Pill Renderer CVSS 4.0MEDIUM 4.6
  • TI-2023-24769 Frappe vulnerable to HTML injection by any Desk user CVSS 3.1MEDIUM 5.4
See all 48 →

Sources