Frappe has Possibility of Remote Code Execution due to improper validation
Priority LOW 31CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
Frappe is a full-stack web application framework. Prior to versions 14.91.0 and 15.52.0, a system user was able to create certain documents in a specific way that could lead to remote code execution. Versions 14.9.1 and 15.52.0 contain a patch for the vulnerability. There's no workaround; an upgrade is required.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00721 54th percentileScored 2026-11-07
Fix Fixed frappe (frappe): 14.91.0, 15.52.0frappe (PyPI): 14.91.0, 15.52.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| frappe | frappe | before 14.91.0; 15.0.0 to before 15.52.0 | 14.91.0, 15.52.0 | Patch available | CNA |
| — | frappe (PyPI) | before 14.91.0 | 14.91.0 | Patch available | GHSA-v342-4xr9-x3q3 |
| — | frappe (PyPI) | 15.0.0 to before 15.52.0 | 15.52.0 | Patch available | GHSA-v342-4xr9-x3q3 |
- frappe Vendorfrappe Affected before 14.91.0; 15.0.0 to before 15.52.0 Fixed in 14.91.0, 15.52.0 Patch available CNA
- frappe (PyPI) Vendor— Affected before 14.91.0 Fixed in 14.91.0 Patch available GHSA-v342-4xr9-x3q3
- frappe (PyPI) Vendor— Affected 15.0.0 to before 15.52.0 Fixed in 15.52.0 Patch available GHSA-v342-4xr9-x3q3
Remediation
- Fix · CNA frappe (frappe) Fixed in 14.91.0, 15.52.0
- Fix · GHSA-v342-4xr9-x3q3 frappe (PyPI) Fixed in 14.91.0 Advisory →
- Fix · GHSA-v342-4xr9-x3q3 frappe (PyPI) Fixed in 15.52.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-30213
- 2026-10-03 Alias added: GHSA-v342-4xr9-x3q3
References
More Frappe vulnerabilities
- TI-2025-35319 ERPNEXT v15.67.0 was discovered to contain multiple SQL injection vulnerabilities in the… CVSS 3.1MEDIUM 6.5
- TI-2025-35318 Frappe Framework v15.72.4 was discovered to contain a SQL injection vulnerability via the… CVSS 3.1MEDIUM 6.5
- TI-2022-20104 Path traversal in Frappe CVSS 3.1MEDIUM 6.5
- TI-2025-35317 A stored cross-site scripting (XSS) vulnerability in the blog post feature of ERPNEXT… CVSS 3.1MEDIUM 5.4
- TI-2026-03168 Frappe Framework 16.10.0 - Stored DOM XSS in Tag Pill Renderer CVSS 4.0MEDIUM 4.6
- TI-2023-24769 Frappe vulnerable to HTML injection by any Desk user CVSS 3.1MEDIUM 5.4
Sources
- CVE-2025-30213 · CVE Program
- CVE-2025-30213 · NVD
- FIRST EPSS
- GHSA-v342-4xr9-x3q3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences