Read the docs
TI-2025-21551 Aliases CVE-2025-30215GHSA-fhg8-qxh5-7q3w

NATS-Server Fails to Authorize Certain Jetstream Admin APIs

Priority HIGH 74CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.

Summary

NATS-Server is a High-Performance server for NATS.io, the cloud and edge native messaging system. In versions starting from 2.2.0 but prior to 2.10.27 and 2.11.1, the management of JetStream assets happens with messages in the $JS. subject namespace in the system account; this is partially exposed into regular accounts to allow account holders to manage their assets. Some of the JS API requests were missing access controls, allowing any user with JS management permissions in any account to perform certain administrative actions on any JS asset in any other account. At least one of the unprotected APIs allows for data destruction. None of the affected APIs allow disclosing stream contents. This vulnerability is fixed in v2.11.1 or v2.10.27.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00601 49th percentileScored 2026-11-07
Fix Fixed nats-server (nats-io): 2.10.27, 2.11.1github.com/nats-io/nats-server/v2 (Go): 2.11.1, 2.10.27

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
backstagenats-server2.2.0 to before 2.10.27; 2.11.0-RC.1 to before 2.11.12.10.27, 2.11.1Patch availableCNA
—github.com/nats-io/nats-server/v2 (Go)2.11.0-RC.1 to before 2.11.12.11.1Patch availableGHSA-fhg8-qxh5-7q3w
—github.com/nats-io/nats-server/v2 (Go)2.2.0 to before 2.10.272.10.27Patch availableGHSA-fhg8-qxh5-7q3w
  • nats-server Vendorbackstage Affected 2.2.0 to before 2.10.27; 2.11.0-RC.1 to before 2.11.1 Fixed in 2.10.27, 2.11.1 Patch available CNA
  • github.com/nats-io/nats-server/v2 (Go) Vendor— Affected 2.11.0-RC.1 to before 2.11.1 Fixed in 2.11.1 Patch available GHSA-fhg8-qxh5-7q3w
  • github.com/nats-io/nats-server/v2 (Go) Vendor— Affected 2.2.0 to before 2.10.27 Fixed in 2.10.27 Patch available GHSA-fhg8-qxh5-7q3w

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:linuxfoundation:nats-server:*:*:*:*:*:*:*:*——backstage
  • cpe:2.3:a:linuxfoundation:nats-server:*:*:*:*:*:*:*:* Versions — — ·backstage

Remediation

  • Fix · CNA nats-server (nats-io) Fixed in 2.10.27, 2.11.1
  • Fix · GHSA-fhg8-qxh5-7q3w github.com/nats-io/nats-server/v2 (Go) Fixed in 2.11.1 Advisory →
  • Fix · GHSA-fhg8-qxh5-7q3w github.com/nats-io/nats-server/v2 (Go) Fixed in 2.10.27 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Critical. Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat Trusted Profile Analyzer

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-30215
  2. 2026-10-03 Alias added: GHSA-fhg8-qxh5-7q3w

References

  • TI-2026-33119 Malware in 42 @tanstack/* packages exfiltrates cloud credentials, GitHub tokens, and SSH keys KEVCVSS 3.1CRITICAL 9.6
  • TI-2018-10499 Integer overflow in backstage kernel KEVCVSS 3.0HIGH 7.8
  • TI-2024-08998 Remote Code Execution in kedro-org/kedro CVSS 3.0CRITICAL 9.8
  • TI-2023-12294 Dragonfly2 vulnerable to hard coded cyptographic key CVSS 3.1CRITICAL 9.8
  • TI-2021-12074 Authentication vulnerability in MOSN v.0.23.0 allows attacker to escalate privileges via… CVSS 3.1CRITICAL 9.8
  • TI-2019-04061 runc through 1.0-rc6, as used in Docker before 18.09.2 and other products, allows… CVSS 3.1HIGH 8.6
See all 662 →

Sources