Frappe has possibility of SQL injection due to improper validations
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
Frappe is a full-stack web application framework. Prior to versions 14.93.2 and 15.55.0, a SQL Injection vulnerability has been identified in Frappe Framework which could allow a malicious actor to access sensitive information. Versions 14.93.2 and 15.55.0 contain a patch for the issue. No known workarounds are available.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| frappe | frappe | before 14.93.2; 15.0.0 to before 15.55.0 | 14.93.2, 15.55.0 | Patch available | CNA |
| — | frappe (PyPI) | before 14.93.2 | 14.93.2 | Patch available | GHSA-6phg-4wmq-h5h3 |
| — | frappe (PyPI) | 15.0.0 to before 15.55.0 | 15.55.0 | Patch available | GHSA-6phg-4wmq-h5h3 |
- frappe Vendorfrappe Affected before 14.93.2; 15.0.0 to before 15.55.0 Fixed in 14.93.2, 15.55.0 Patch available CNA
- frappe (PyPI) Vendor— Affected before 14.93.2 Fixed in 14.93.2 Patch available GHSA-6phg-4wmq-h5h3
- frappe (PyPI) Vendor— Affected 15.0.0 to before 15.55.0 Fixed in 15.55.0 Patch available GHSA-6phg-4wmq-h5h3
Remediation
- Fix · CNA frappe (frappe) Fixed in 14.93.2, 15.55.0
- Fix · GHSA-6phg-4wmq-h5h3 frappe (PyPI) Fixed in 14.93.2 Advisory →
- Fix · GHSA-6phg-4wmq-h5h3 frappe (PyPI) Fixed in 15.55.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-30217
- 2026-10-03 Alias added: GHSA-6phg-4wmq-h5h3
References
More Frappe vulnerabilities
- TI-2025-35319 ERPNEXT v15.67.0 was discovered to contain multiple SQL injection vulnerabilities in the… CVSS 3.1MEDIUM 6.5
- TI-2025-35318 Frappe Framework v15.72.4 was discovered to contain a SQL injection vulnerability via the… CVSS 3.1MEDIUM 6.5
- TI-2022-20104 Path traversal in Frappe CVSS 3.1MEDIUM 6.5
- TI-2025-35317 A stored cross-site scripting (XSS) vulnerability in the blog post feature of ERPNEXT… CVSS 3.1MEDIUM 5.4
- TI-2026-03168 Frappe Framework 16.10.0 - Stored DOM XSS in Tag Pill Renderer CVSS 4.0MEDIUM 4.6
- TI-2023-24769 Frappe vulnerable to HTML injection by any Desk user CVSS 3.1MEDIUM 5.4
Sources
- CVE-2025-30217 · CVE Program
- CVE-2025-30217 · NVD
- FIRST EPSS
- GHSA-6phg-4wmq-h5h3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences