jooby-pac4j: deserialization of untrusted data
Priority MEDIUM 41CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
Jooby is a web framework for Java and Kotlin. The pac4j io.jooby.internal.pac4j.SessionStoreImpl#get module deserializes untrusted data. This vulnerability is fixed in 2.17.0 (2.x) and 3.7.0 (3.x).
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00663 51st percentileScored 2026-11-07
Fix Fixed jooby (jooby-project): 3.7.0, 2.17.0io.jooby:jooby-pac4j (Maven): 2.17.0, 3.7.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jooby-project | jooby | 3.0.0.M1 to before 3.7.0; before 2.17.0 | 3.7.0, 2.17.0 | Patch available | CNA |
| — | io.jooby:jooby-pac4j (Maven) | before 2.17.0 | 2.17.0 | Patch available | GHSA-7c5v-895v-w4q5 |
| — | io.jooby:jooby-pac4j (Maven) | 3.0.0.M1 to before 3.7.0 | 3.7.0 | Patch available | GHSA-7c5v-895v-w4q5 |
- jooby Vendorjooby-project Affected 3.0.0.M1 to before 3.7.0; before 2.17.0 Fixed in 3.7.0, 2.17.0 Patch available CNA
- io.jooby:jooby-pac4j (Maven) Vendor— Affected before 2.17.0 Fixed in 2.17.0 Patch available GHSA-7c5v-895v-w4q5
- io.jooby:jooby-pac4j (Maven) Vendor— Affected 3.0.0.M1 to before 3.7.0 Fixed in 3.7.0 Patch available GHSA-7c5v-895v-w4q5
Remediation
- Fix · CNA jooby (jooby-project) Fixed in 3.7.0, 2.17.0
- Fix · GHSA-7c5v-895v-w4q5 io.jooby:jooby-pac4j (Maven) Fixed in 2.17.0 Advisory →
- Fix · GHSA-7c5v-895v-w4q5 io.jooby:jooby-pac4j (Maven) Fixed in 3.7.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-31129
- 2026-10-03 Alias added: GHSA-7c5v-895v-w4q5
- 2026-10-16 EPSS moved to the 50th–90th percentile
References
Other 5
- https://github.com/jooby-project/jooby/security/advisories/GHSA-7c5v-895v-w4q5
- https://github.com/jooby-project/jooby/commit/3e13562cf36d7407813eae464e0f4b598de15692
- https://github.com/jooby-project/jooby/blob/v2.x/modules/jooby-pac4j/src/main/java/io/jooby/internal/pac4j/SessionStoreImpl.java#L39-L45
- https://github.com/jooby-project/jooby/blob/v3.6.1/modules/jooby-pac4j/src/main/java/io/jooby/internal/pac4j/SessionStoreImpl.java#L77-L84
- https://github.com/jooby-project/jooby
Sources
- CVE-2025-31129 · CVE Program
- CVE-2025-31129 · NVD
- FIRST EPSS
- GHSA-7c5v-895v-w4q5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences