Improper Scope Validation in the open Endpoint of tauri-plugin-shell
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
The Tauri shell plugin allows access to the system shell. Prior to 2.2.1, the Tauri shell plugin exposes functionality to execute code and open programs on the system. The open endpoint of this plugin is designed to allow open functionality with the system opener (e.g. xdg-open on Linux). This was meant to be restricted to a reasonable number of protocols like https or mailto by default. This default restriction was not functional due to improper validation of the allowed protocols, allowing for potentially dangerous protocols like file://, smb://, or nfs:// and others to be opened by the system registered protocol handler. By passing untrusted user input to the open endpoint these potentially dangerous protocols can be abused to gain remote code execution on the system. This either requires direct exposure of the endpoint to application users or code execution in the frontend of a Tauri application. This vulnerability is fixed in 2.2.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tauri-apps | plugins-workspace | before 2.2.1 | 2.2.1 | Patch available | CNA |
| — | tauri-plugin-shell (crates.io) | before 2.2.1 | 2.2.1 | Patch available | GHSA-c9pr-q8gx-3mgp |
| — | @tauri-apps/plugin-shell (npm) | before 2.2.1 | 2.2.1 | Patch available | GHSA-c9pr-q8gx-3mgp |
- plugins-workspace Vendortauri-apps Affected before 2.2.1 Fixed in 2.2.1 Patch available CNA
- tauri-plugin-shell (crates.io) Vendor— Affected before 2.2.1 Fixed in 2.2.1 Patch available GHSA-c9pr-q8gx-3mgp
- @tauri-apps/plugin-shell (npm) Vendor— Affected before 2.2.1 Fixed in 2.2.1 Patch available GHSA-c9pr-q8gx-3mgp
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:tauri:plugin-shell:*:*:*:*:*:rust:*:* | before 2.2.1 | Vulnerable | tauri-apps |
| cpe:2.3:a:tauri:plugin-shell:*:*:*:*:*:node.js:*:* | before 2.2.1 | Vulnerable | tauri-apps |
- cpe:2.3:a:tauri:plugin-shell:*:*:*:*:*:rust:*:* Versions before 2.2.1 Vulnerable ·tauri-apps
- cpe:2.3:a:tauri:plugin-shell:*:*:*:*:*:node.js:*:* Versions before 2.2.1 Vulnerable ·tauri-apps
Remediation
- Fix · CNA plugins-workspace (tauri-apps) Fixed in 2.2.1
- Fix · GHSA-c9pr-q8gx-3mgp tauri-plugin-shell (crates.io) Fixed in 2.2.1 Advisory →
- Fix · GHSA-c9pr-q8gx-3mgp @tauri-apps/plugin-shell (npm) Fixed in 2.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-31477
- 2026-10-03 Alias added: GHSA-c9pr-q8gx-3mgp
References
Patch 1
Sources
- CVE-2025-31477 · CVE Program
- CVE-2025-31477 · NVD
- FIRST EPSS
- GHSA-c9pr-q8gx-3mgp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences