Read the docs
TI-2025-22662 Aliases CVE-2025-31481GHSA-cg3c-245w-728m

GraphQL query operations security can be bypassed

Priority HIGH 72CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.

Summary

API Platform Core is a system to create hypermedia-driven REST and GraphQL APIs. Using the Relay special node type you can bypass the configured security on an operation. This vulnerability is fixed in 4.0.22 and 3.4.17.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00475 41st percentileScored 2026-11-07
Fix Fixed core (api-platform): 4.0.22, 3.4.17api-platform/graphql (Packagist): 4.0.22, 3.4.17, 4.1.5+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
api-platformcore4.0.0 to before 4.0.22; before 3.4.174.0.22, 3.4.17Patch availableCNA
—api-platform/graphql (Packagist)4.0.0-alpha.1 to before 4.0.224.0.22Patch availableGHSA-cg3c-245w-728m
—api-platform/core (Packagist)4.0.0-alpha.1 to before 4.0.224.0.22Patch availableGHSA-cg3c-245w-728m
—api-platform/graphql (Packagist)before 3.4.173.4.17Patch availableGHSA-cg3c-245w-728m
—api-platform/core (Packagist)before 3.4.173.4.17Patch availableGHSA-cg3c-245w-728m
—api-platform/graphql (Packagist)4.1.0-alpha.1 to before 4.1.54.1.5Patch availableGHSA-cg3c-245w-728m
—api-platform/core (Packagist)4.1.0-alpha.1 to before 4.1.54.1.5Patch availableGHSA-cg3c-245w-728m
  • core Vendorapi-platform Affected 4.0.0 to before 4.0.22; before 3.4.17 Fixed in 4.0.22, 3.4.17 Patch available CNA
  • api-platform/graphql (Packagist) Vendor— Affected 4.0.0-alpha.1 to before 4.0.22 Fixed in 4.0.22 Patch available GHSA-cg3c-245w-728m
  • api-platform/core (Packagist) Vendor— Affected 4.0.0-alpha.1 to before 4.0.22 Fixed in 4.0.22 Patch available GHSA-cg3c-245w-728m
  • api-platform/graphql (Packagist) Vendor— Affected before 3.4.17 Fixed in 3.4.17 Patch available GHSA-cg3c-245w-728m
  • api-platform/core (Packagist) Vendor— Affected before 3.4.17 Fixed in 3.4.17 Patch available GHSA-cg3c-245w-728m
  • api-platform/graphql (Packagist) Vendor— Affected 4.1.0-alpha.1 to before 4.1.5 Fixed in 4.1.5 Patch available GHSA-cg3c-245w-728m
  • api-platform/core (Packagist) Vendor— Affected 4.1.0-alpha.1 to before 4.1.5 Fixed in 4.1.5 Patch available GHSA-cg3c-245w-728m

Remediation

  • Fix · CNA core (api-platform) Fixed in 4.0.22, 3.4.17
  • Fix · GHSA-cg3c-245w-728m api-platform/graphql (Packagist) Fixed in 4.0.22 Advisory →
  • Fix · GHSA-cg3c-245w-728m api-platform/core (Packagist) Fixed in 4.0.22 Advisory →
  • Fix · GHSA-cg3c-245w-728m api-platform/graphql (Packagist) Fixed in 3.4.17 Advisory →
  • Fix · GHSA-cg3c-245w-728m api-platform/core (Packagist) Fixed in 3.4.17 Advisory →
  • Fix · GHSA-cg3c-245w-728m api-platform/graphql (Packagist) Fixed in 4.1.5 Advisory →
  • Fix · GHSA-cg3c-245w-728m api-platform/core (Packagist) Fixed in 4.1.5 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-31481
  2. 2026-10-03 Alias added: GHSA-cg3c-245w-728m

References

  • TI-2023-25779 API Platform Core can leak exceptions message that may contain sensitive information CVSS 3.1MEDIUM 5.3
  • TI-2026-39072 API Platform Core: Missing IRI type check enables resource type confusion CVSS 3.1MEDIUM 6.5
  • TI-2025-16989 GraphQl securityAfterResolver not called CVSS 3.1MEDIUM 4.4
  • TI-2025-22666 GraphQL grant on a property might be cached with different objects CVSS 3.1HIGH 7.5
  • TI-2023-10878 Secured properties in API Platform Core may be accessible within collections CVSS 3.1HIGH 7.7
  • TI-2019-15828 API Platform version from 2.2.0 to 2.3.5 contains an Incorrect Access Control… CVSS 3.0MEDIUM 6.5
See all 7 →

Sources