Code injection in Jenkins Templating Engine Plugin
Priority MEDIUM 43CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
In Jenkins Templating Engine Plugin 2.5.3 and earlier, libraries defined in folders are not subject to sandbox protection, allowing attackers with Item/Configure permission to execute arbitrary code in the context of the Jenkins controller JVM.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0131 70th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:templating-engine (Maven): 2.5.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Templating Engine Plugin | up to 2.5.3 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:templating-engine (Maven) | before 2.5.4 | 2.5.4 | Patch available | GHSA-4vjp-327p-w4qv |
- Jenkins Templating Engine Plugin VendorJenkins Affected up to 2.5.3 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:templating-engine (Maven) Vendor— Affected before 2.5.4 Fixed in 2.5.4 Patch available GHSA-4vjp-327p-w4qv
Remediation
- Fix · GHSA-4vjp-327p-w4qv org.jenkins-ci.plugins:templating-engine (Maven) Fixed in 2.5.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-31722
- 2026-10-03 Alias added: GHSA-4vjp-327p-w4qv
References
More Jenkins Templating Engine vulnerabilities
- TI-2021-04726 Protection mechanism failure in Jenkins Templating Engine Plugin CVSS 3.1HIGH 8.8
Sources
- CVE-2025-31722 · CVE Program
- CVE-2025-31722 · NVD
- FIRST EPSS
- GHSA-4vjp-327p-w4qv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences