Yii does not prevent XSS in scenarios where fallback error renderer is used
Priority LOW 27CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Yii is an open source PHP web framework. Prior to 1.1.31, yiisoft/yii is vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used. Upgrade yiisoft/yii to version 1.1.31 or higher.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0025 16th percentileScored 2026-11-07
Fix Fixed yii (yiisoft): 1.1.31yiisoft/yii (Packagist): 1.1.31
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Yiiframework | yii | before 1.1.31 | 1.1.31 | Patch available | CNA |
| — | yiisoft/yii (Packagist) | before 1.1.31 | 1.1.31 | Patch available | GHSA-7r2v-8wxr-3ch5 |
- yii VendorYiiframework Affected before 1.1.31 Fixed in 1.1.31 Patch available CNA
- yiisoft/yii (Packagist) Vendor— Affected before 1.1.31 Fixed in 1.1.31 Patch available GHSA-7r2v-8wxr-3ch5
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:yiiframework:yii:*:*:*:*:*:*:*:* | before 1.1.31 | Vulnerable | Yiiframework |
- cpe:2.3:a:yiiframework:yii:*:*:*:*:*:*:*:* Versions before 1.1.31 Vulnerable ·Yiiframework
Remediation
- Fix · CNA yii (yiisoft) Fixed in 1.1.31
- Fix · GHSA-7r2v-8wxr-3ch5 yiisoft/yii (Packagist) Fixed in 1.1.31 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-32027
- 2026-10-03 Alias added: GHSA-7r2v-8wxr-3ch5
References
More Yiiframework Yii vulnerabilities
- TI-2024-38344 Yii 2 before 2.0.52 mishandles the attaching of behavior that is defined by an __class… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-11920 Unsafe deserialization in Yii 2 CVSS 3.1CRITICAL 10.0
- TI-2024-04634 Unsafe Reflection in base Component class in yiisoft/yii2 CVSS 3.1CRITICAL 9.1
- TI-2025-02355 yiisoft Yii2 MockClass.php generate deserialization CVSS 4.0MEDIUM 5.3
- TI-2025-02354 yiisoft Yii2 SortableIterator.php getIterator deserialization CVSS 4.0MEDIUM 5.3
- TI-2023-11755 SQL injection vulnerability found in Yii Framework Yii 2 Framework before v.2.0.47 allows… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-32027 · CVE Program
- CVE-2025-32027 · NVD
- FIRST EPSS
- GHSA-7r2v-8wxr-3ch5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences