Apollo Gateway Query Planner Vulnerable to Excessive Resource Consumption via Named Fragment Expansion
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-770.
Summary
Apollo Gateway provides utilities for combining multiple GraphQL microservices into a single GraphQL endpoint. Prior to 2.10.1, a vulnerability in Apollo Gateway allowed queries with deeply nested and reused named fragments to be prohibitively expensive to query plan, specifically during named fragment expansion. Named fragments were being expanded once per fragment spread during query planning, leading to exponential resource usage when deeply nested and reused fragments were involved. This could lead to excessive resource consumption and denial of service. This has been remediated in @apollo/gateway version 2.10.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| apollographql | federation | before 2.10.1 | 2.10.1 | Patch available | CNA |
| — | @apollo/gateway (npm) | before 2.10.1 | 2.10.1 | Patch available | GHSA-q2f9-x4p4-7xmh |
- federation Vendorapollographql Affected before 2.10.1 Fixed in 2.10.1 Patch available CNA
- @apollo/gateway (npm) Vendor— Affected before 2.10.1 Fixed in 2.10.1 Patch available GHSA-q2f9-x4p4-7xmh
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apollographql:apollo_gateway:*:*:*:*:*:node.js:*:* | before 2.10.1 | Vulnerable | apollographql |
- cpe:2.3:a:apollographql:apollo_gateway:*:*:*:*:*:node.js:*:* Versions before 2.10.1 Vulnerable ·apollographql
Remediation
- Fix · CNA federation (apollographql) Fixed in 2.10.1
- Fix · GHSA-q2f9-x4p4-7xmh @apollo/gateway (npm) Fixed in 2.10.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-32030
- 2026-10-03 Alias added: GHSA-q2f9-x4p4-7xmh
References
Advisory 2
More apollographql Apollo Gateway vulnerabilities
- TI-2024-29063 Apollo Query Planner and Apollo Gateway may infinitely loop on sufficiently complex queries CVSS 3.1HIGH 7.5
- TI-2025-23155 Apollo Gateway Query Planner Vulnerable to Excessive Resource Consumption via Optimization Bypass CVSS 3.1HIGH 7.5
Sources
- CVE-2025-32030 · CVE Program
- CVE-2025-32030 · NVD
- FIRST EPSS
- GHSA-q2f9-x4p4-7xmh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences