Cascading protection is not preventing file reversions
Priority LOW 3CWE-281Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Improper Preservation of Permissions vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/editpage/IntroMessageBuilder.Php, includes/Permissions/PermissionManager.Php, includes/Permissions/RestrictionStore.Php. This issue affects MediaWiki: before 1.42.6, 1.43.1.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00402 34th percentileScored 2026-11-07
Fix Fixed MediaWiki (Wikimedia Foundation): 1.42.6, 1.43.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Wikimedia Foundation | MediaWiki | before 1.42.6, 1.43.1 | 1.42.6, 1.43.1 | Patch available | CNA |
- MediaWiki VendorWikimedia Foundation Affected before 1.42.6, 1.43.1 Fixed in 1.42.6, 1.43.1 Patch available CNA
Remediation
- Fix · CNA MediaWiki (Wikimedia Foundation) Fixed in 1.42.6, 1.43.1
Timeline
- 2026-10-02 Threatist record created from CVE-2025-32697
- 2026-10-03 Alias added: GHSA-f626-w254-w424
References
More Wikimedia Foundation vulnerabilities
- TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
- TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
- TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
- TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
- TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
- TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
Sources
- CVE-2025-32697 · CVE Program
- CVE-2025-32697 · NVD
- FIRST EPSS
- GHSA-f626-w254-w424 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences