Read the docs
TI-2025-23763 Aliases CVE-2025-32698GHSA-hh2q-7x5p-j2g2

LogPager.php: Restriction enforcer functions do not correctly enforce suppression restrictions

Priority LOW 12CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Active
Attack complexity
Low
Attack requirements
Present
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-200.

Summary

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/logging/LogPager.Php. This issue affects MediaWiki: before 1.39.12, 1.42.6, 1.43.1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00437 38th percentileScored 2026-11-07
Fix Fixed MediaWiki (Wikimedia Foundation): 1.39.12, 1.42.6, 1.43.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Wikimedia FoundationMediaWikibefore 1.39.12, 1.42.6, 1.43.11.39.12, 1.42.6, 1.43.1Patch availableCNA
  • MediaWiki VendorWikimedia Foundation Affected before 1.39.12, 1.42.6, 1.43.1 Fixed in 1.39.12, 1.42.6, 1.43.1 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:*——mediawiki
  • cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions — — ·mediawiki

Remediation

  • Fix · CNA MediaWiki (Wikimedia Foundation) Fixed in 1.39.12, 1.42.6, 1.43.1

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Wikimedia Foundation MediaWiki 1.39.12, 1.42.6, 1.43.1

    4 records Highest priority Priority LOW 4 LOW

    Other records, highest priority first

    • TI-2025-23764 Potential javascript injection attack enabled by Unicode normalization in Action APIPriority LOW 11
    • TI-2025-23761 "reupload-own" restriction can be bypassed by reverting filePriority LOW 3
    • TI-2025-03048 i18n XSS vulnerability in HTMLMultiSelectField when sections are usedPriority LOW 3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-32698
  2. 2026-10-03 Alias added: GHSA-hh2q-7x5p-j2g2

References

  • TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
  • TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
  • TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
  • TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
  • TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
  • TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
See all 255 →

Sources