ses's global contour bindings leak into Compartment lexical scope
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-497.
Summary
SES safely executes third-party JavaScript 'strict' mode programs in compartments that have no excess authority in their global scope. Prior to version 1.12.0, web pages and web extensions using `ses` and the Compartment API to evaluate third-party code in an isolated execution environment that have also elsewhere used `const`, `let`, and `class` bindings in the top-level scope of a `<script>` tag will have inadvertently revealed these bindings in the lexical scope of third-party code. This issue has been patched in version 1.12.0. Workarounds for this issue involve either avoiding top-level `let`, `const`, or `class` bindings in `<script>` tags, or change these to `var` bindings to be reflected on `globalThis`.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| endojs | endo | before 1.12.0 | 1.12.0 | Patch available | CNA |
| — | ses (npm) | before 1.12.0 | 1.12.0 | Patch available | GHSA-h9w6-f932-gq62 |
- endo Vendorendojs Affected before 1.12.0 Fixed in 1.12.0 Patch available CNA
- ses (npm) Vendor— Affected before 1.12.0 Fixed in 1.12.0 Patch available GHSA-h9w6-f932-gq62
Remediation
- Fix · CNA endo (endojs) Fixed in 1.12.0
- Fix · GHSA-h9w6-f932-gq62 ses (npm) Fixed in 1.12.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-32792
- 2026-10-03 Alias added: GHSA-h9w6-f932-gq62
References
Sources
- CVE-2025-32792 · CVE Program
- CVE-2025-32792 · NVD
- FIRST EPSS
- GHSA-h9w6-f932-gq62 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences