Read the docs
TI-2025-23838 Aliases CVE-2025-32801GHSA-hv8v-455m-2grc

Loading a malicious hook library can lead to local privilege escalation

Priority LOW 36CWE-94Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-94.

Summary

Kea configuration and API directives can be used to load a malicious hook library. Many common configurations run Kea as root, leave the API entry points unsecured by default, and/or place the control sockets in insecure paths. This issue affects Kea versions 2.4.0 through 2.4.1, 2.6.0 through 2.6.2, and 2.7.0 through 2.7.8.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00299 22nd percentileScored 2026-11-07
Fix Fixed Red Hat: 1 advisory

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCKea2.4.0 – 2.4.1; 2.6.0 – 2.6.2; 2.7.0 – 2.7.8—No fix listedCNA
  • Kea VendorISC Affected 2.4.0 – 2.4.1; 2.6.0 – 2.6.2; 2.7.0 – 2.7.8 Fixed in — No fix listed CNA

Remediation

Red Hat 1 advisory

  • RHSA-2025:9178 Released 2025-06-17 · Red Hat rating Important
    kea security update
    • Red Hat Enterprise Linux AppStream (v. 10) kea-doc-2.6.3-1.el10_0, kea-hooks-2.6.3-1.el10_0
    • Red Hat Enterprise Linux BaseOS (v. 10) kea-2.6.3-1.el10_0, kea-libs-2.6.3-1.el10_0
    • Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) kea-keama-2.6.3-1.el10_0

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux AppStream (v. 10)Fixed RHSA-2025:9178
Red Hat Enterprise Linux BaseOS (v. 10)Fixed RHSA-2025:9178
Red Hat Enterprise Linux CodeReady Linux Builder (v. 10)Fixed RHSA-2025:9178

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-32801
  2. 2026-10-03 Alias added: GHSA-hv8v-455m-2grc

References

Advisory 1

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-1999-00042 Command execution via shell metachars in INN daemon (innd) 1.5 using "newgroup" and… CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2025-27240 Cache poisoning attacks with unsolicited RRs CVSS 3.1HIGH 8.6
See all 285 →

Sources