Read the docs
TI-2025-23904 Aliases CVE-2025-32873GHSA-8j24-cjrq-gr2m

Resource allocation without limits in djangoproject Django

Priority MEDIUM 45CWE-770Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · Low
Fix status
Partial Red Hat: 8 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-770.

Summary

An issue was discovered in Django 4.2 before 4.2.21, 5.1 before 5.1.9, and 5.2 before 5.2.1. The django.utils.html.strip_tags() function is vulnerable to a potential denial-of-service (slow performance) when processing inputs containing large sequences of incomplete HTML tags. The template filter striptags is also vulnerable, because it is built on top of strip_tags().

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.1431 96th percentileScored 2026-11-07
Fix Partial Django (djangoproject): 4.2.21, 5.1.9, 5.2.1Django (PyPI): 4.2.21, 5.1.9, 5.2.1Red Hat: 8 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
djangoprojectDjango4.2 to before 4.2.21; 5.1 to before 5.1.9; 5.2 to before 5.2.14.2.21, 5.1.9, 5.2.1Patch availableCNA
—Django (PyPI)4.2 to before 4.2.214.2.21Patch availableGHSA-8j24-cjrq-gr2m
—Django (PyPI)5.1 to before 5.1.95.1.9Patch availableGHSA-8j24-cjrq-gr2m
—Django (PyPI)5.2 to before 5.2.15.2.1Patch availableGHSA-8j24-cjrq-gr2m
  • Django Vendordjangoproject Affected 4.2 to before 4.2.21; 5.1 to before 5.1.9; 5.2 to before 5.2.1 Fixed in 4.2.21, 5.1.9, 5.2.1 Patch available CNA
  • Django (PyPI) Vendor— Affected 4.2 to before 4.2.21 Fixed in 4.2.21 Patch available GHSA-8j24-cjrq-gr2m
  • Django (PyPI) Vendor— Affected 5.1 to before 5.1.9 Fixed in 5.1.9 Patch available GHSA-8j24-cjrq-gr2m
  • Django (PyPI) Vendor— Affected 5.2 to before 5.2.1 Fixed in 5.2.1 Patch available GHSA-8j24-cjrq-gr2m

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:*4.2.0 to before 4.2.21; 5.1 to before 5.1.9Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:5.2:*:*:*:*:*:*:*5.2Vulnerabledjangoproject
  • cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions 4.2.0 to before 4.2.21; 5.1 to before 5.1.9 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:5.2:*:*:*:*:*:*:* Versions 5.2 Vulnerable ·djangoproject

Remediation

  • Fix · CNA Django (djangoproject) Fixed in 4.2.21, 5.1.9, 5.2.1
  • Fix · GHSA-8j24-cjrq-gr2m Django (PyPI) Fixed in 4.2.21 Advisory →
  • Fix · GHSA-8j24-cjrq-gr2m Django (PyPI) Fixed in 5.1.9 Advisory →
  • Fix · GHSA-8j24-cjrq-gr2m Django (PyPI) Fixed in 5.2.1 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Ansible Automation Platform 2AffectedNo fix yet: Fix deferred
Red Hat Certification for Red Hat Enterprise Linux 7AffectedNo fix yet: Fix deferred
Red Hat Discovery 1AffectedNo fix yet: Fix deferred
Red Hat OpenStack Platform 16.2AffectedNo fix yet: Fix deferred
Red Hat OpenStack Platform 17.1AffectedNo fix yet: Fix deferred
Red Hat OpenStack Platform 18.0AffectedNo fix yet: Fix deferred
Red Hat Satellite 6AffectedNo fix yet: Fix deferred
Red Hat Update Infrastructure 4 for Cloud ProvidersAffectedNo fix yet: Fix deferred

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-32873
  2. 2026-10-03 Alias added: GHSA-8j24-cjrq-gr2m

References

  • TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
  • TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
  • TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
  • TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
  • TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
  • TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
See all 156 →

Sources