Read the docs
TI-2025-23926 Aliases CVE-2025-32901GHSA-m48p-p8gp-9jxf

In KDE Connect before 1.33.0 on Android, malicious device IDs (sent via broadcast UDP) could cause an application crash.

Priority LOW 19CWE-1287Published · Updated

Key facts

Attack vector
Adjacent network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

In KDE Connect before 1.33.0 on Android, malicious device IDs (sent via broadcast UDP) could cause an application crash.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00192 8th percentileScored 2026-11-07
Fix Fixed KDEConnect (KDE): 1.33.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
KDEKDEConnectbefore 1.33.01.33.0Patch availableCNA
  • KDEConnect VendorKDE Affected before 1.33.0 Fixed in 1.33.0 Patch available CNA

Remediation

  • Fix · CNA KDEConnect (KDE) Fixed in 1.33.0

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    KDE KDEConnect 1.33.0

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

    • TI-2025-23924 In KDE Connect before 1.33.0 on Android, a packet can be crafted that causes two paired…Priority LOW 19

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-32901
  2. 2026-10-03 Alias added: GHSA-m48p-p8gp-9jxf

References

  • TI-2026-73452 OS command injection in KDE Dolphin via crafted folder names CVSS 4.0HIGH 7.1
  • TI-2004-00806 Multiple integer overflows in xpdf 2.0 and 3.0, and other packages that use xpdf code… CVSS 2.0HIGH 10.0
  • TI-2012-03853 Type confusion in KDE Konqueror CVSS 3.1HIGH 8.8
  • TI-2004-00807 Multiple integer overflows in xpdf 3.0, and other packages that use xpdf code such as… CVSS 2.0HIGH 10.0
  • TI-2005-00011 Multiple vulnerabilities in fliccd, when installed setuid root as part of the kdeedu… CVSS 2.0HIGH 10.0
  • TI-2004-01022 Buffer overflow in the Gfx::doImage function in Gfx.cc for xpdf 3.00, and other products… CVSS 2.0HIGH 9.3
See all 206 →

Sources