Compromised xrpl.js versions 4.2.1, 4.2.2, 4.2.3, 4.2.4, and 2.14.2
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-506.
Summary
xrpl.js is a JavaScript/TypeScript API for interacting with the XRP Ledger in Node.js and the browser. Versions 4.2.1, 4.2.2, 4.2.3, and 4.2.4 of xrpl.js were compromised and contained malicious code designed to exfiltrate private keys. Version 2.14.2 is also malicious, though it is less likely to lead to exploitation as it is not compatible with other 2.x versions. Anyone who used one of these versions should stop immediately and rotate any private keys or secrets used with affected systems. Users of xrpl.js should pgrade to version 4.2.5 or 2.14.3 to receive a patch. To secure funds, think carefully about whether any keys may have been compromised by this supply chain attack, and mitigate by sending funds to secure wallets, and/or rotating keys. If any account's master key is potentially compromised, disable the key.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| XRPLF | xrpl.js | 4.2.1 to before 4.2.5; = 2.14.2 | 4.2.5 | Patch available | CNA |
| — | xrpl (npm) | 4.2.1 to before 4.2.5 | 4.2.5 | Patch available | GHSA-33qr-m49q-rxfx |
| — | xrpl (npm) | 2.14.2 to before 2.14.3 | 2.14.3 | Patch available | GHSA-33qr-m49q-rxfx |
- xrpl.js VendorXRPLF Affected 4.2.1 to before 4.2.5; = 2.14.2 Fixed in 4.2.5 Patch available CNA
- xrpl (npm) Vendor— Affected 4.2.1 to before 4.2.5 Fixed in 4.2.5 Patch available GHSA-33qr-m49q-rxfx
- xrpl (npm) Vendor— Affected 2.14.2 to before 2.14.3 Fixed in 2.14.3 Patch available GHSA-33qr-m49q-rxfx
Remediation
- Fix · CNA xrpl.js (XRPLF) Fixed in 4.2.5
- Fix · GHSA-33qr-m49q-rxfx xrpl (npm) Fixed in 4.2.5 Advisory →
- Fix · GHSA-33qr-m49q-rxfx xrpl (npm) Fixed in 2.14.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-32965
- 2026-10-03 Alias added: GHSA-33qr-m49q-rxfx
References
Other 5
- https://github.com/XRPLF/xrpl.js/security/advisories/GHSA-33qr-m49q-rxfx
- https://www.aikido.dev/blog/xrp-supplychain-attack-official-npm-package-infected-with-crypto-stealing-backdoor
- https://xrpl.org/docs/tutorials/how-tos/manage-account-settings/assign-a-regular-key-pair
- https://xrpl.org/docs/tutorials/how-tos/manage-account-settings/disable-master-key-pair
- https://github.com/XRPLF/xrpl.js
Sources
- CVE-2025-32965 · CVE Program
- CVE-2025-32965 · NVD
- FIRST EPSS
- GHSA-33qr-m49q-rxfx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences