The lesscss script service allows cache clearing without programming right
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-285.
Summary
XWiki is a generic wiki platform. In versions starting from 6.1-milestone-1 to before 15.10.12, from 16.0.0-rc-1 to before 16.4.3, and from 16.5.0-rc-1 to before 16.8.0-rc-1, the script API of the LESS compiler in XWiki is incorrectly checking for rights when calling the cache cleaning API, making it possible to clean the cache without having programming right. The only impact of this is a slowdown in XWiki execution as the caches are re-filled. As this vulnerability requires script right to exploit, and script right already allows unlimited execution of scripts, the additional impact due to this vulnerability is low. This issue has been patched in versions 15.10.12, 16.4.3, and 16.8.0-rc-1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| XWiki | xwiki-platform | 6.1-milestone-1 to before 15.10.12; 16.0.0-rc-1 to before 16.4.3; 16.5.0-rc-1 to before 16.8.0-rc-1 | 15.10.12, 16.4.3, 16.8.0-rc-1 | Patch available | CNA |
| — | org.xwiki.platform:xwiki-platform-lesscss-script (Maven) | 6.1-milestone-1 to before 15.10.12 | 15.10.12 | Patch available | GHSA-rp38-24m3-rx87 |
| — | org.xwiki.platform:xwiki-platform-lesscss-script (Maven) | 16.0.0-rc-1 to before 16.4.3 | 16.4.3 | Patch available | GHSA-rp38-24m3-rx87 |
| — | org.xwiki.platform:xwiki-platform-lesscss-script (Maven) | 16.5.0-rc-1 to before 16.8.0-rc-1 | 16.8.0-rc-1 | Patch available | GHSA-rp38-24m3-rx87 |
- xwiki-platform VendorXWiki Affected 6.1-milestone-1 to before 15.10.12; 16.0.0-rc-1 to before 16.4.3; 16.5.0-rc-1 to before 16.8.0-rc-1 Fixed in 15.10.12, 16.4.3, 16.8.0-rc-1 Patch available CNA
- org.xwiki.platform:xwiki-platform-lesscss-script (Maven) Vendor— Affected 6.1-milestone-1 to before 15.10.12 Fixed in 15.10.12 Patch available GHSA-rp38-24m3-rx87
- org.xwiki.platform:xwiki-platform-lesscss-script (Maven) Vendor— Affected 16.0.0-rc-1 to before 16.4.3 Fixed in 16.4.3 Patch available GHSA-rp38-24m3-rx87
- org.xwiki.platform:xwiki-platform-lesscss-script (Maven) Vendor— Affected 16.5.0-rc-1 to before 16.8.0-rc-1 Fixed in 16.8.0-rc-1 Patch available GHSA-rp38-24m3-rx87
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:xwiki:xwiki:*:*:*:*:*:*:*:* | 6.2 to before 15.10.12; 16.0.0 to before 16.4.3; 16.5.0 to before 16.8.0 | Vulnerable | XWiki |
| cpe:2.3:a:xwiki:xwiki:6.1:-:*:*:*:*:*:* | 6.1 | Vulnerable | XWiki |
| cpe:2.3:a:xwiki:xwiki:6.1:milestone1:*:*:*:*:*:* | 6.1 milestone1 | Vulnerable | XWiki |
| cpe:2.3:a:xwiki:xwiki:6.1:milestone2:*:*:*:*:*:* | 6.1 milestone2 | Vulnerable | XWiki |
| cpe:2.3:a:xwiki:xwiki:6.1:rc1:*:*:*:*:*:* | 6.1 rc1 | Vulnerable | XWiki |
- cpe:2.3:a:xwiki:xwiki:*:*:*:*:*:*:*:* Versions 6.2 to before 15.10.12; 16.0.0 to before 16.4.3; 16.5.0 to before 16.8.0 Vulnerable ·XWiki
- cpe:2.3:a:xwiki:xwiki:6.1:-:*:*:*:*:*:* Versions 6.1 Vulnerable ·XWiki
- cpe:2.3:a:xwiki:xwiki:6.1:milestone1:*:*:*:*:*:* Versions 6.1 milestone1 Vulnerable ·XWiki
- cpe:2.3:a:xwiki:xwiki:6.1:milestone2:*:*:*:*:*:* Versions 6.1 milestone2 Vulnerable ·XWiki
- cpe:2.3:a:xwiki:xwiki:6.1:rc1:*:*:*:*:*:* Versions 6.1 rc1 Vulnerable ·XWiki
Remediation
- Fix · CNA xwiki-platform (xwiki) Fixed in 15.10.12, 16.4.3, 16.8.0-rc-1
- Fix · GHSA-rp38-24m3-rx87 org.xwiki.platform:xwiki-platform-lesscss-script (Maven) Fixed in 15.10.12 Advisory →
- Fix · GHSA-rp38-24m3-rx87 org.xwiki.platform:xwiki-platform-lesscss-script (Maven) Fixed in 16.4.3 Advisory →
- Fix · GHSA-rp38-24m3-rx87 org.xwiki.platform:xwiki-platform-lesscss-script (Maven) Fixed in 16.8.0-rc-1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-32972
- 2026-10-03 Alias added: GHSA-rp38-24m3-rx87
References
Patch 2
More Xwiki vulnerabilities
- TI-2025-18595 Remote code execution as guest via SolrSearchMacros request in xwiki KEVCVSS 3.1CRITICAL 9.8
- TI-2023-25214 Remote code execution through the section parameter in Administration as guest in XWiki Platform CVSS 3.1CRITICAL 10.0
- TI-2025-23500 XWiki Platform vulnerable to SQL injection through getdeleteddocuments.vm template sort parameter CVSS 4.0CRITICAL 9.3
- TI-2025-23979 org.xwiki.platform:xwiki-platform-rest-server allows SQL injection in query endpoint of REST API CVSS 4.0CRITICAL 9.3
- TI-2024-20829 XWiki Platform: Remote code execution from account via SearchSuggestSourceSheet CVSS 3.1CRITICAL 10.0
- TI-2024-14375 XWiki Remote Code Execution vulnerability via user registration CVSS 3.1CRITICAL 10.0
Sources
- CVE-2025-32972 · CVE Program
- CVE-2025-32972 · NVD
- FIRST EPSS
- GHSA-rp38-24m3-rx87 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences