Improper output encoding in xwiki-platform
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-269.
Summary
XWiki is a generic wiki platform. In versions starting from 15.9-rc-1 to before 15.10.8 and from 16.0.0-rc-1 to before 16.2.0, the required rights analysis doesn't consider TextAreas with default content type. When editing a page, XWiki warns since version 15.9 when there is content on the page like a script macro that would gain more rights due to the editing. This analysis doesn't consider certain kinds of properties, allowing a user to put malicious scripts in there that will be executed after a user with script, admin, or programming rights edited the page. Such a malicious script could impact the confidentiality, integrity and availability of the whole XWiki installation. This issue has been patched in versions 15.10.8 and 16.2.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| XWiki | xwiki-platform | 15.9-rc-1 to before 15.10.8; 16.0.0-rc-1 to before 16.2.0 | 15.10.8, 16.2.0 | Patch available | CNA |
| — | org.xwiki.platform:xwiki-platform-security-requiredrights-default (Maven) | 15.9-rc-1 to before 15.10.8 | 15.10.8 | Patch available | GHSA-mvgm-3rw2-7j4r |
| — | org.xwiki.platform:xwiki-platform-security-requiredrights-default (Maven) | 16.0.0-rc-1 to before 16.2.0 | 16.2.0 | Patch available | GHSA-mvgm-3rw2-7j4r |
- xwiki-platform VendorXWiki Affected 15.9-rc-1 to before 15.10.8; 16.0.0-rc-1 to before 16.2.0 Fixed in 15.10.8, 16.2.0 Patch available CNA
- org.xwiki.platform:xwiki-platform-security-requiredrights-default (Maven) Vendor— Affected 15.9-rc-1 to before 15.10.8 Fixed in 15.10.8 Patch available GHSA-mvgm-3rw2-7j4r
- org.xwiki.platform:xwiki-platform-security-requiredrights-default (Maven) Vendor— Affected 16.0.0-rc-1 to before 16.2.0 Fixed in 16.2.0 Patch available GHSA-mvgm-3rw2-7j4r
Remediation
- Fix · CNA xwiki-platform (xwiki) Fixed in 15.10.8, 16.2.0
- Fix · GHSA-mvgm-3rw2-7j4r org.xwiki.platform:xwiki-platform-security-requiredrights-default (Maven) Fixed in 15.10.8 Advisory →
- Fix · GHSA-mvgm-3rw2-7j4r org.xwiki.platform:xwiki-platform-security-requiredrights-default (Maven) Fixed in 16.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-32974
- 2026-10-03 Alias added: GHSA-mvgm-3rw2-7j4r
References
Patch 2
More Xwiki vulnerabilities
- TI-2025-18595 Remote code execution as guest via SolrSearchMacros request in xwiki KEVCVSS 3.1CRITICAL 9.8
- TI-2023-25214 Remote code execution through the section parameter in Administration as guest in XWiki Platform CVSS 3.1CRITICAL 10.0
- TI-2025-23500 XWiki Platform vulnerable to SQL injection through getdeleteddocuments.vm template sort parameter CVSS 4.0CRITICAL 9.3
- TI-2025-23979 org.xwiki.platform:xwiki-platform-rest-server allows SQL injection in query endpoint of REST API CVSS 4.0CRITICAL 9.3
- TI-2024-20829 XWiki Platform: Remote code execution from account via SearchSuggestSourceSheet CVSS 3.1CRITICAL 10.0
- TI-2024-14375 XWiki Remote Code Execution vulnerability via user registration CVSS 3.1CRITICAL 10.0
Sources
- CVE-2025-32974 · CVE Program
- CVE-2025-32974 · NVD
- FIRST EPSS
- GHSA-mvgm-3rw2-7j4r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences