OP5 Monitor <= 7.1.9 Authenticated Command Execution via command_test.php
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass, Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-306 and CWE-78.
Summary
An authenticated command injection vulnerability exists in OP5 Monitor through version 7.1.9 via the 'cmd_str' parameter in the command_test.php endpoint. A user with access to the web interface can exploit the 'Test this command' feature to execute arbitrary shell commands as the unprivileged web application user. The vulnerability resides in the configuration section of the application and requires valid login credentials with access to the command testing functionality. This issue is fixed in version 7.2.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ITRS Group | OP5 Monitor | up to 7.1.9 | — | No fix listed | CNA |
- OP5 Monitor VendorITRS Group Affected up to 7.1.9 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-34115
- 2026-10-03 Alias added: GHSA-gv2v-p8xm-xh87
References
More ITRS Group vulnerabilities
- TI-2021-03194 ITRS Group monitor-ninja scheduled_reports.php sql injection CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-34115 · CVE Program
- CVE-2025-34115 · NVD
- FIRST EPSS
- GHSA-gv2v-p8xm-xh87 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences