Deciso OPNsense < 25.7.4 /interfaces_ppps_edit.php ptpid Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
In Deciso OPNsense before 25.7.4, when creating an "Interfaces: Devices: Point-to-Point" entry, the value of the parameter ptpid is not sanitized of HTML-related characters/strings. This value is directly displayed when visiting the page/interfaces_assign.php, which can result in stored cross-site scripting. The attacker must be authenticated with at-least "Interfaces: PPPs: Edit" permission. This vulnerability has been addressed by the vendor in the product release notes as "ui: legacy_html_escape_form_data() was not escaping keys only data elements."
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA OPNsense (Deciso) Fixed in 25.7.4
Timeline
- 2026-10-02 Threatist record created from CVE-2025-34182
- 2026-10-03 Alias added: GHSA-v8ch-859h-ggwh
References
More Deciso vulnerabilities
- TI-2026-01692 OS command injection in Deciso OPNsense CVSS 3.0MEDIUM 6.8
- TI-2025-12519 Path traversal in Deciso OPNsense CVSS 3.0MEDIUM 4.5
Sources
- CVE-2025-34182 · CVE Program
- CVE-2025-34182 · NVD
- FIRST EPSS
- GHSA-v8ch-859h-ggwh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences