Logstash Improper Certificate Validation in TCP output
Priority LOW 28CWE-295Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-295.
Summary
Improper certificate validation in Logstash's TCP output could lead to a man-in-the-middle (MitM) attack in “client” mode, as hostname verification in TCP output was not being performed when the ssl_verification_mode => full was set.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0018 7th percentileScored 2026-11-07
Fix Fixed Logstash (Elastic): 8.17.6, 8.18.1, 9.0.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Elastic | Logstash | 8.0.0 to before 8.17.6; 8.18.0 to before 8.18.1; 9.0.0 to before 9.0.1 | 8.17.6, 8.18.1, 9.0.1 | Patch available | CNA |
- Logstash VendorElastic Affected 8.0.0 to before 8.17.6; 8.18.0 to before 8.18.1; 9.0.0 to before 9.0.1 Fixed in 8.17.6, 8.18.1, 9.0.1 Patch available CNA
Remediation
- Fix · CNA Logstash (Elastic) Fixed in 8.17.6, 8.18.1, 9.0.1
Timeline
- 2026-10-02 Threatist record created from CVE-2025-37730
- 2026-10-03 Alias added: GHSA-qrf7-ph5v-mj2v
References
More Elastic vulnerabilities
- TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
- TI-2015-01295 The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-02491 The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which… KEVCVSS 3.1HIGH 8.1
- TI-2018-12328 Kibana versions before 6.4.3 and 5.6.13 contain an arbitrary file inclusion flaw in the… CVSS 3.0CRITICAL 9.8
- TI-2023-15037 Elasticsearch StackOverflow vulnerability CVSS 3.1HIGH 7.5
- TI-2021-05135 Information disclosure in Elasticsearch CVSS 3.1MEDIUM 6.5
Sources
- CVE-2025-37730 · CVE Program
- CVE-2025-37730 · NVD
- FIRST EPSS
- GHSA-qrf7-ph5v-mj2v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences