ata: pata_pxa: Fix potential NULL pointer dereference in pxa_ata_probe()
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-476.
Summary
In the Linux kernel, the following vulnerability has been resolved: ata: pata_pxa: Fix potential NULL pointer dereference in pxa_ata_probe() devm_ioremap() returns NULL on error. Currently, pxa_ata_probe() does not check for this case, which can result in a NULL pointer dereference. Add NULL check after devm_ioremap() to prevent this issue.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.36 and later | 5.4.293, 5.10.237, 5.15.181, 6.1.135, 6.6.88, 6.12.24, 6.13.12, 6.14.3, 6.15 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.36 and later Fixed in 5.4.293, 5.10.237, 5.15.181, 6.1.135, 6.6.88, 6.12.24, 6.13.12, 6.14.3, 6.15 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 2.6.36 to before 5.4.293; 5.5 to before 5.10.237; 5.11 to before 5.15.181; 5.16 to before 6.1.135; 6.2 to before 6.6.88; 6.7 to before 6.12.24; 6.13 to before 6.13.12; 6.14 to before 6.14.3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc1:*:*:*:*:*:* | 6.15 rc1 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.36 to before 5.4.293; 5.5 to before 5.10.237; 5.11 to before 5.15.181; 5.16 to before 6.1.135; 6.2 to before 6.6.88; 6.7 to before 6.12.24; 6.13 to before 6.13.12; 6.14 to before 6.14.3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc1:*:*:*:*:*:* Versions 6.15 rc1 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.293, 5.10.237, 5.15.181, 6.1.135, 6.6.88, 6.12.24, 6.13.12, 6.14.3, 6.15
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-37758
- 2026-10-03 Alias added: GHSA-fx77-mj6g-j23r
References
Patch 9
- https://git.kernel.org/stable/c/a551f75401793ba8075d7f46ffc931ce5151f03f
- https://git.kernel.org/stable/c/17d5e6e915fad5a261db3698c9c5bbe702102d7c
- https://git.kernel.org/stable/c/d0d720f9282839b9db625a376c02a1426a16b0ae
- https://git.kernel.org/stable/c/2dc53c7a0c1f57b082931facafa804a7ca32a9a6
- https://git.kernel.org/stable/c/5b09bf6243b0bc0ae58bd9efdf6f0de5546f8d06
- https://git.kernel.org/stable/c/ee2b0301d6bfe16b35d57947687c664ecb815775
- https://git.kernel.org/stable/c/c022287f6e599422511aa227dc6da37b58d9ceac
- https://git.kernel.org/stable/c/2ba9e4c69207777bb0775c7c091800ecd69de144
- https://git.kernel.org/stable/c/ad320e408a8c95a282ab9c05cdf0c9b95e317985
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-37758 · CVE Program
- CVE-2025-37758 · NVD
- FIRST EPSS
- GHSA-fx77-mj6g-j23r · GitHub Advisory Database · CC BY 4.0
- CVE-2025-37758 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences