iommu/amd: Fix potential buffer overflow in parse_ivrs_acpihid
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-787 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: iommu/amd: Fix potential buffer overflow in parse_ivrs_acpihid There is a string parsing logic error which can lead to an overflow of hid or uid buffers. Comparing ACPIID_LEN against a total string length doesn't take into account the lengths of individual hid and uid buffers so the check is insufficient in some cases. For example if the length of hid string is 4 and the length of the uid string is 260, the length of str will be equal to ACPIID_LEN + 1 but uid string will overflow uid buffer which size is 256. The same applies to the hid string with length 13 and uid string with length 250. Check the length of hid and uid strings separately to prevent buffer overflow. Found by Linux Verification Center (linuxtesting.org) with SVACE.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.7 and later | 5.4.294, 5.10.238, 5.15.182, 6.1.138, 6.6.90, 6.12.28, 6.14.6, 6.15 | Patch available | CNA |
- Linux VendorLinux Affected 4.7 and later Fixed in 5.4.294, 5.10.238, 5.15.182, 6.1.138, 6.6.90, 6.12.28, 6.14.6, 6.15 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.7 to before 5.4.294; 5.5 to before 5.10.238; 5.11 to before 5.15.182; 5.16 to before 6.1.138; 6.2 to before 6.6.90; 6.7 to before 6.12.28; 6.13 to before 6.14.6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc1:*:*:*:*:*:* | 6.15 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc2:*:*:*:*:*:* | 6.15 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc3:*:*:*:*:*:* | 6.15 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.15:rc4:*:*:*:*:*:* | 6.15 rc4 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.7 to before 5.4.294; 5.5 to before 5.10.238; 5.11 to before 5.15.182; 5.16 to before 6.1.138; 6.2 to before 6.6.90; 6.7 to before 6.12.28; 6.13 to before 6.14.6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc1:*:*:*:*:*:* Versions 6.15 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc2:*:*:*:*:*:* Versions 6.15 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc3:*:*:*:*:*:* Versions 6.15 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.15:rc4:*:*:*:*:*:* Versions 6.15 rc4 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.294, 5.10.238, 5.15.182, 6.1.138, 6.6.90, 6.12.28, 6.14.6, 6.15
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-37927
- 2026-10-03 Alias added: GHSA-jrcg-ffmc-qfvv
References
Patch 8
- https://git.kernel.org/stable/c/2b65060c84ee4d8dc64fae6d2728b528e9e832e1
- https://git.kernel.org/stable/c/a65ebfed65fa62797ec1f5f1dcf7adb157a2de1e
- https://git.kernel.org/stable/c/466d9da267079a8d3b69fa72dfa3a732e1f6dbb5
- https://git.kernel.org/stable/c/c3f37faa71f5d26dd2144b3f2b14525ec8f5e41f
- https://git.kernel.org/stable/c/13d67528e1ae4486e9ab24b70122fab104c73c29
- https://git.kernel.org/stable/c/10d901a95f8e766e5aa0bb9a983fb41271f64718
- https://git.kernel.org/stable/c/c8bdfc0297965bb13fa439d36ca9c4f7c8447f0f
- https://git.kernel.org/stable/c/8dee308e4c01dea48fc104d37f92d5b58c50b96c
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-37927 · CVE Program
- CVE-2025-37927 · NVD
- FIRST EPSS
- GHSA-jrcg-ffmc-qfvv · GitHub Advisory Database · CC BY 4.0
- CVE-2025-37927 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences